Bug 200688 - timidity++ fails to run on FC 5
timidity++ fails to run on FC 5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: timidity++ (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
:
: 288921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-30 17:43 EDT by Dan O'Brien
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.13.2-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 22:25:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan O'Brien 2006-07-30 17:43:10 EDT
Description of problem:

Timidity++ fails to run on FC 5 (seems to be an old problem since FC 2).
Complains about not finding the Enlightened Sound daemon.

timidity O*.mid   
esd: No such file or directory
Couldn't open Enlightened sound daemon (`e')

Version-Release number of selected component (if applicable):

rpm -qi timidity++
Name        : timidity++                   Relocations: (not relocatable)
Version     : 2.13.2                            Vendor: Red Hat, Inc.
Release     : 1.2.1                         Build Date: Sun 12 Feb 2006 12:50:16
PM EST
Install Date: Sun 30 Jul 2006 02:07:51 PM EDT      Build Host:
ls20-bc1-13.build.redhat.com
Group       : Applications/Multimedia       Source RPM:
timidity++-2.13.2-1.2.1.src.rpm

How reproducible:

Every time.

Steps to Reproduce:
1. As listed above.
2.
3.
  
Actual results:

As listed above.


Expected results:


Additional info:

Google searched this and found these references to this problem:

http://www.fedoraforum.org/forum/showthread.php?t=109205

and from here a link to older version of FC

http://linux.derkeiler.com/Mailing-Lists/Fedora/2005-01/2277.html
Comment 1 Nigel Jones 2007-07-27 19:03:26 EDT
FC 5 is now retired, can you see if you get the error/problem with FC6 or greater?
Comment 2 Dan O'Brien 2007-07-27 19:16:25 EDT
/home/dmobrien/ringtones: timidity *.mid                
esd: No such file or directory
Couldn't open Enlightened sound daemon (`e')
/home/dmobrien/ringtones: uname -a
Linux yorky.danobrien.ws 2.6.22.1-27.fc7 #1 SMP Tue Jul 17 17:13:26 EDT 2007
i686 i686 i386 GNU/Linux
/home/dmobrien/ringtones: rpm -q timidity++
timidity++-2.13.2-1.2.2
/home/dmobrien/ringtones: 
Comment 3 Hans de Goede 2007-08-17 09:39:11 EDT
Erm, why isn't this fixed yet? It should be trivially easy to fix. Then again
with the coming of pulseaudio to F-8, now might not be the best time to fix this.
Comment 4 Martin Tarenskeen 2007-09-16 16:58:42 EDT
I have seen this problem ever since I started with Fedora. Now I'm using Fedora
F7, and still the bug exists. BTW: I use timidity with the argument "-Os" and
then it works fine. The problem occurs when running timidity without specifying
the output device on the commandline. It still is a stupid bug though.
 
Comment 5 Martin Tarenskeen 2007-09-18 02:38:57 EDT
This problem seems to be caused by the TiMidity-2.13.0-detect.patch.
If this - not properly working - patch is removed from the SPEC file, bugs
#200699 and #288921 will be fixed. I have tested this.
 
Comment 6 Hans de Goede 2007-10-13 02:34:42 EDT
*** Bug 288921 has been marked as a duplicate of this bug. ***
Comment 7 Hans de Goede 2007-10-13 03:30:07 EDT
Hi all,

Nigel is no longer the timidity maintainer, Jindrich Novy and I are now
maintaing timidity, reassigning to me and looking into this as time permits.
Comment 8 Hans de Goede 2007-10-14 15:43:45 EDT
I've rewritten the which output to use patch, using the detection code which was
already there. timidity++-2.13.2-4 which includes the fix, should show up in
updates-testing soon. When it hits updates-testing our updates-system will add a
comment about this to this bug. Please let me know if this fixes things for you.
Comment 9 Fedora Update System 2007-10-15 17:31:25 EDT
timidity++-2.13.2-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update timidity++'
Comment 10 Dan O'Brien 2007-10-15 19:08:18 EDT
/home/dmobrien: sudo yum --enablerepo=updates-testing update timidity++
Password:
freshrpms                 100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 222 kB    00:00     
updates                   100% |=========================| 2.3 kB    00:00     
adobe-linux-i386          100% |=========================|  951 B    00:00     
Setting up Update Process
Could not find update match for timidity++
No Packages marked for Update
/home/dmobrien: uname -a
Linux yorky.danobrien.ws 2.6.22.9-91.fc7 #1 SMP Thu Sep 27 23:10:59 EDT 2007
i686 i686 i386 GNU/Linux
/home/dmobrien: 
Comment 11 Hans de Goede 2007-10-16 02:09:45 EDT
You probably were to quick and your mirror wasn't synced tet, try again and
thanks for testing!
Comment 12 Martin Tarenskeen 2007-10-16 02:24:14 EDT
It seems to work perfectly now. With or without options, or started from the
gnome-menu. (I'm running iton FC7). Thanks. 
Comment 13 Dan O'Brien 2007-10-16 06:12:45 EDT
/home/dmobrien: timidity ./ringtones/simpsons.mid
Requested buffer size 32768, fragment size 8192
ALSA pcm 'default' set buffer size 33868, period size 3760 bytes
Playing ./ringtones/simpsons.mid
MIDI file: ./ringtones/simpsons.mid
Format: 1  Tracks: 11  Divisions: 480
Track name: voice/horn
Track name: harp
Track name: strings arco
Track name: strings pizz
Track name: glock/xyl
Track name: flute/clar
Track name: tpt
Track name: sax
Track name: timpani
Track name: percussion
(Simpsons Theme)Playing time: ~93 seconds
Notes cut: 0
Notes lost totally: 0
/home/dmobrien: 

PERFECT!
Comment 14 Fedora Update System 2007-10-17 22:25:36 EDT
timidity++-2.13.2-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.