Bug 289061 - Could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
Summary: Could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-XML-SAX
Version: 5.3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Marcela Mašláňová
QA Contact: BaseOS QE
URL:
Whiteboard:
Keywords:
: 223057 438291 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-13 11:03 UTC by srinivas
Modified: 2018-10-27 15:40 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-01-06 08:56:52 UTC


Attachments (Terms of Use)
attaching the upgrade logs (71.18 KB, text/plain)
2007-09-13 11:03 UTC, srinivas
no flags Details
patch XML::SAX (1.40 KB, patch)
2008-05-09 13:38 UTC, Marcela Mašláňová
no flags Details | Diff
patch XML::SAX (1.40 KB, patch)
2008-05-09 13:38 UTC, Marcela Mašláňová
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0008 normal SHIPPED_LIVE perl-XML-SAX and perl-XML-LibXML bug fix update 2010-01-06 08:56:49 UTC

Description srinivas 2007-09-13 11:03:07 UTC
Description of problem:
Error messages are observed when an upgrade is carried out from RHEL 4.4 to 
RHEL 5.1
Below are the error messages are observed in /root/upgrade.log

"BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.5/i386-
linux-thread-multi/XML/LibXML.pm line 11.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-
thread-multi/XML/LibXML/SAX/Parser.pm line "
"Could not parse file '/usr/share/applications/redhat-evolution.desktop': 
Failed to open file " 

Version-Release number of selected component (if applicable):
anaconda-11.1.2.75-1

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4U4 selecting all packages
2.Now upgrade the system to RHEL5.1
3.Check /root/upgrade.log for failed messages
  
Actual results:

No errors should be observed when the upgrade is performed.

Expected results:

No errors should be observed when the upgrade is performed.

Additional info:

Comment 1 srinivas 2007-09-13 11:03:07 UTC
Created attachment 194491 [details]
attaching the upgrade logs

Comment 2 Suzanne Yeghiayan 2008-02-01 19:27:42 UTC
Since this bugzilla was filed against pre-RHEL 5.1 and was not addressed in 5.2
Beta via FasTrack, moved to 5.3 FasTrack.

Comment 4 Marcela Mašláňová 2008-05-09 12:41:31 UTC
*** Bug 438291 has been marked as a duplicate of this bug. ***

Comment 5 Marcela Mašláňová 2008-05-09 12:43:10 UTC
*** Bug 223057 has been marked as a duplicate of this bug. ***

Comment 7 Marcela Mašláňová 2008-05-09 13:34:33 UTC
perl-XML-SAX has problematic file ParserDetails.ini, which is now filled in
scriptlets. The manual update on x86_64 RHEL-5 is working for me.

Comment 8 Marcela Mašláňová 2008-05-09 13:38:18 UTC
Created attachment 304940 [details]
patch XML::SAX

Patch which works for me.

Comment 9 Marcela Mašláňová 2008-05-09 13:38:24 UTC
Created attachment 304941 [details]
patch XML::SAX

Patch which works for me.

Comment 10 Stepan Kasal 2008-05-12 14:50:51 UTC
Comment on attachment 304941 [details]
patch XML::SAX

Identical to the previous one.

Comment 11 Stepan Kasal 2008-05-12 14:52:20 UTC
Comment on attachment 304940 [details]
patch XML::SAX

It seems that Source1: filter-requires-xmlsax.sh is not used in the spec file,
so if this patch works, then it should also work without it.

Comment 12 Stepan Kasal 2008-05-12 15:16:19 UTC
Comment on attachment 304940 [details]
patch XML::SAX

Oops.  The Source1 is already trere in perl-XML-SAX-0.14-5.  So it just means
that part of diff is already in the main tree.
So it seems adding %post and %preun is what is needed.

Comment 13 RHEL Product and Program Management 2008-07-21 23:09:20 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 14 RHEL Product and Program Management 2009-03-26 16:55:08 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 17 Michal Nowak 2009-10-15 09:00:14 UTC
FYI: It's easily reproducible, when installing all ('*') at S390x -- rhel-5.4.

Comment 23 Martin Poole 2009-11-02 17:31:33 UTC
Making BZ public since there is nothing confidential in comments or attachments.

Comment 30 errata-xmlrpc 2010-01-06 08:56:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0008.html


Note You need to log in before you can comment on or make changes to this bug.