Bug 438291 - Could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
Could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
Status: CLOSED DUPLICATE of bug 289061
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl-XML-LibXML (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Marcela Mašláňová
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-20 04:43 EDT by Michal Nowak
Modified: 2013-03-07 21:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 08:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2008-03-20 04:43:34 EDT
Description of problem:

While installing perl-XML-LibXML via pup/pirut (as a dependency for
cman-2.0.80-1.el5) I got this warning

perl-XML-LibXML - 1.58-5.i386
could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX

file /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/ParserDetails.ini belongs to
perl-XML-SAX-0.14-5 which was installed as new dependency too but prio to
perl-XML-LibXML.

399 Mar 20 09:21:58 Installed: perl-XML-NamespaceSupport - 1.09-1.2.1.noarch
400 Mar 20 09:21:58 Installed: perl-XML-SAX - 0.14-5.noarch
401 ...
402 Mar 20 09:21:59 Installed: perl-XML-LibXML-Common - 0.13-8.2.2.i386
403 Mar 20 09:22:00 Installed: perl-XML-LibXML - 1.58-5.i386
404 Mar 20 09:22:00 could not find ParserDetails.ini in
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX
405 
406 Mar 20 09:22:01 Updated: cman - 2.0.80-1.el5.i386

Might be some regression, ParserDetails.ini is mentioned in spec file:

100 * Sun Apr 18 2004 Ville Skyttä <ville.skytta at iki.fi> - 1.58-1
101 - #121168
102 - Update to 1.58.
104 - Handle ParserDetails.ini parser registration.


Version-Release number of selected component (if applicable):
perl-XML-LibXML-1.58-5

How reproducible:

on first install of perl-XML-LibXML and perl-XML-SAX

newman@dhcp-lab-198 ~ $ sudo rpm -e perl-XML-LibXML --nodeps perl-XML-SAX
newman@dhcp-lab-198 ~ $ rpmquery -f
/usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/ParserDetails.ini 
error: file /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX/ParserDetails.ini: No such
file or directory
newman@dhcp-lab-198 ~ $ sudo yum install perl-XML-LibXML perl-XML-SAXLoading
"security" plugin
Loading "rhnplugin" plugin
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00     
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package perl-XML-SAX.noarch 0:0.14-5 set to be updated
---> Package perl-XML-LibXML.i386 0:1.58-5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 perl-XML-LibXML         i386       1.58-5           rhel-client       231 k
Installing for dependencies:
 perl-XML-SAX            noarch     0.14-5           rhel-i386-server-5   75 k

Transaction Summary
=============================================================================
Install      2 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 306 k
Is this ok [y/N]: y
Downloading Packages:
(2/2): perl-XML-SAX-0.14- 100% |=========================|  75 kB    00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: perl-XML-SAX                 ######################### [1/2] 
  Installing: perl-XML-LibXML              ######################### [2/2] 
could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX

Installed: perl-XML-LibXML.i386 0:1.58-5
Dependency Installed: perl-XML-SAX.noarch 0:0.14-5
Complete!


Steps to Reproduce:
1. remove perl-XML-LibXML and perl-XML-SAX
2. install them again
3. see the warning
  
Actual results:
warning and maybe some unconfigured parser

Expected results:
no warning and configured parser (?)

Additional info:

Actually, I dunno whether the warning about something what did not happen
(configuration) is important or not, but I believe we should avoid all
unnecessary warnings.
Comment 1 Marcela Mašláňová 2008-03-20 05:51:57 EDT
ParserDetails.ini is %ghost in perl-XML-SAX. Something must changed in code of
later versions, because the problem disappear f.e. in F-8. 
Comment 2 Michal Nowak 2008-04-02 07:30:12 EDT
It's gone for me in rawhide.
Comment 3 Marcela Mašláňová 2008-05-09 08:41:30 EDT

*** This bug has been marked as a duplicate of 289061 ***
Comment 4 Natarajan 2009-06-26 02:18:51 EDT
[root@xxxx client]# rpm -ivh perl-*
warning: perl-Net-Telnet-3.03-5.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 37017186
Preparing...                ########################################### [100%]
   1:perl-XML-NamespaceSuppo########################################### [ 20%]
   2:perl-XML-SAX           ########################################### [ 40%]
   3:perl-XML-LibXML-Common ########################################### [ 60%]
   4:perl-Net-Telnet        ########################################### [ 80%]
   5:perl-XML-LibXML        ########################################### [100%]
could not find ParserDetails.ini in /usr/lib/perl5/vendor_perl/5.8.8/XML/SAX

Note You need to log in before you can comment on or make changes to this bug.