Bug 289361 - Actual file on translation status page not getting updated!
Actual file on translation status page not getting updated!
Status: CLOSED NOTABUG
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
medium Severity low
: ---
: ---
Assigned To: Dimitris Glezos
Diego Búrigo Zacarão
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 10:49 EDT by Ankit Patel
Modified: 2007-09-17 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 10:18:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ankit Patel 2007-09-13 10:49:16 EDT
Description of problem:
I just submitted the smolt.tip.gu.po translation through transifex submit page:
https://publictest5.fedora.redhat.com/submit/module/smolt

Earlier there was problem with status not getting updated & I filed a bug for
that also, which has been resolved now:
https://bugzilla.redhat.com/show_bug.cgi?id=288841

But, the other thing i found that the actual file showing on status page is
older one only. It's not getting updated. So, if i  want to download the latest
version of the file, i am not able to do it.

e.g http://translate.fedoraproject.org/POT/smolt.tip/smolt.tip.gu.po still shows
the older file with 1 fuzzy message "98% (67/0/1)", but the actual status is
shown on the page is "76% (65/3/17)", which is quite strange...


Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Download smolt.tip.gu.po file from the status page
2. Translate & submit it through
https://publictest5.fedora.redhat.com/submit/module/smolt
3. Check the status on http://translate.fedoraproject.org/languages/gu/fedora-8
4. Try to open the file from that page itself:
http://translate.fedoraproject.org/POT/smolt.tip/smolt.tip.gu.po , which  is
quite different than what you have submitted...
  
Actual results:
Translation status is getting updated, but actual translation files are not
getting updated on translate.fp.org status page.

Expected results:
Translation files also should be updated along with the translations status...

Additional info:
Comment 1 Dimitris Glezos 2007-09-17 10:18:27 EDT
Step 2 commits the file instantly. But step 3 needs some hours to be updated
because it is done via a cronjob run 3 times a day currently. So between steps 2
and 3, some hours need to pass.

Also, please note that the statistics and the files shown on the website are
*msgmerged*. This mean that you might commit a 100% file (which isn't msgmerged)
but on the stats page it might appear with lower percentage after it is merged.

From my testing right now, I see that the files are updated correctly and
reflect the translation status. The only thing that differentiates them from the
actual VCS ones is that they are msgmerged.

Closing as a NOTABUG. We can re-open if something new shows up.

Note You need to log in before you can comment on or make changes to this bug.