Bug 289461 - Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5 Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz...
Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: John Matthews
:
Depends On: 370021
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-13 12:53 EDT by Lester Cavey
Modified: 2008-09-18 15:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-18 15:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debug (21.54 KB, application/octet-stream)
2007-11-08 07:07 EST, Maciej Orzechowski
no flags Details

  None (edit)
Description Lester Cavey 2007-09-13 12:53:59 EDT
Description of problem:
Component: Software Updater
Exception Occurred:
Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to
retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Traceback (most recent call last):
  File "/usr/sbin/pup", line 668, in ?
    main()
  File "/usr/sbin/pup", line 664, in main
    pup.run()
  File "/usr/sbin/pup", line 499, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 324, in doRefresh
    self.populateUpdates()
  File "/usr/sbin/pup", line 380, in populateUpdates
    self.updateMetadata.add(repo)
  File "/usr/lib/python2.4/site-packages/yum/update_md.py", line 228, in add
    md = obj.retrieveMD(mdtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 622, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/yum-plugins/rhnplugin.py", line 222, in _YumRepository__get
    raise yum.Errors.RepoError, \
RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5
error was [Errno -1] Metadata file does not match checksum

Local variables in innermost frame:
e: [Errno -1] Metadata file does not match checksum
url: None
text: None
self: rhel-i386-server-5
cache: False
reget: None
relative: repodata/updateinfo.xml.gz
start: None
checkfunc: (<bound method RhnRepo.checkMD of <rhnplugin.RhnRepo object at
0xa001f6c>>, ('updateinfo',), {})
copy_local: 1
end: None
local: //var/cache/yum/rhel-i386-server-5/updateinfo.xml.gz


Version-Release number of selected component (if applicable):


How reproducible:
Applications -> System Tools -> Software Updater

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Package Updater was Retrieving Update Information when it raised the Exception
Occurred message listed above.

Expected results:
Retrieve and install package updates.

Additional info:
Comment 1 Maciej Orzechowski 2007-11-08 07:07:22 EST
Created attachment 251441 [details]
debug

the same problem exists on my RedHat 5 x64
Comment 2 Maciej Orzechowski 2007-11-08 07:13:41 EST
the same problem is showed in 370021  369901 and 250437
Comment 3 Lester Cavey 2008-08-02 16:16:37 EDT
The original summary for this bug was longer than 255 characters, and so it was truncated when Bugzilla was upgraded. The original summary was:

Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5  Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5  Component: Software Updater  Summary: TBf3313d0f rhnplugin.py:222:_YumRepository__get:RepoError: failed to retrieve repodata/updateinfo.xml.gz from rhel-i386-server-5  error was [Errno -1] Metadata file does not match checksum
Comment 4 John Matthews 2008-09-18 15:12:05 EDT
I suspect this was a temporary problem, possibly the client side cache needs to be cleaned.

I'm not able to reproduce this error and marking as CLOSED.

Note You need to log in before you can comment on or make changes to this bug.