Bug 28987 - [drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
Status: CLOSED DUPLICATE of bug 26999
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 02:00 EST by Alexei Podtelezhnikov
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-01 08:23:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (6.03 KB, text/plain)
2001-03-09 03:38 EST, Alexei Podtelezhnikov
no flags Details

  None (edit)
Description Alexei Podtelezhnikov 2001-02-23 02:00:10 EST
The last lines of boot messages for Wolverine look as follows. Note that I 
didn't see that using Fisher. It doesn't affect overall operation however 
aparently.

--------------------------
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 94M
agpgart: Detected AMD Irongate chipset
agpgart: AGP aperture is 64M @ 0xe8000000
ip_conntrack (1023 buckets, 8184 max)
[drm] AGP 0.99 on AMD Irongate @ 0xe8000000 64MB
[drm] Initialized r128 2.1.2 20001215 on minor 63
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_idle] *ERROR* r128_do_wait_for_idle failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_idle] *ERROR* r128_do_wait_for_idle failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_idle] *ERROR* r128_do_wait_for_idle failed!
hdc: ATAPI 32X DVD-ROM drive, 512kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root
ISO 9660 Extensions: Microsoft Joliet Level 3
ISOFS: changing to secondary root
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
[drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!
Comment 1 Glen Foster 2001-02-23 16:56:00 EST
We (Red Hat) should really try to resolve this before next release.
Comment 2 Arjan van de Ven 2001-03-01 04:14:50 EST
This bug is believed to be fixed in our next build. If a build of 2.4.2-0.1.18
or later does not fix it (when it becomes available), please reopen this bug.
Comment 3 Alexei Podtelezhnikov 2001-03-06 02:59:33 EST
The error messages from drm:r128 are still present in
kernel-2.4.2-0.1.19.i686 from recent rawhide.

This is MS-6195 with Athlon 750 MHz and ATI All-in-WOnder 128 PRO.

In addition, the fix to the bug 25920 which is in 2.4.2ac is also omitted. Not 
sure if they depend on each other.
Comment 4 Mike A. Harris 2001-03-06 11:59:26 EST
Everyone that can has r128 cards that has tested this problem out says that
r128 DRI now works and does not lock up.  Please make absolutely sure
that you are running the newest kernel, and the newest XFree86-4.0.2
RPM's from my personal ftp space:  ftp://people.redhat.com/mharris/xfree86

If it still does not work, it almost certainly has to be a different issue
specific to your setup I would think as it is completley unreproduceable.

Please update both bugs when you've tested it out.
Comment 5 Alexei Podtelezhnikov 2001-03-09 03:38:50 EST
Created attachment 12169 [details]
dmesg output
Comment 6 Alexei Podtelezhnikov 2001-03-09 03:46:42 EST
These messages do not lock Xfree86. Everything (but 3d-acceleration) seems to 
be working. This only occurs with Wolverine and more recent kernels. Bug 25920 
contain related Xfree86 log and config files. On shutting-down I see some other 
errors from DRM..
Comment 7 Alexei Podtelezhnikov 2001-03-09 04:34:03 EST
On halt from Gnome login window or logout from KDE, I sometimes get the message:
[drm:drm_release] *ERROR* process 759 dead, freeing lock for context 1
                                 ^^^^^                              ^^^
                                pid of X                         2,3,4,etc

Yes, X restarts automatically each time.
Comment 8 Alexei Podtelezhnikov 2001-03-12 16:28:16 EST
Aparently this bug shows up on Athlon systems with newer Rage 128 chips. I found
an independent confirmation on dri bugzilla:
http://sourceforge.net/tracker/?func=detail&atid=100387&aid=231658&group_id=387
Comment 9 Arjan van de Ven 2001-03-21 12:57:23 EST
Latest kernels from Rawhide should have a fix for this.
Comment 10 Alexei Podtelezhnikov 2001-03-28 12:01:39 EST
The real fix is to reduce color depth from 24 bpp (anaconda and 
Xconfigurator's "best" offering) to 16 bpp. DRI doesn't work at 24 bpp on my 
Rage 128 PF.
Comment 11 Mike A. Harris 2001-03-29 11:51:56 EST
The bug "[drm:r128_do_wait_for_fifo] should be fixed in the latest
XFree86-4.0.3-3 or -4 in rawhide.  You need to have Mesa 3.4-13 as
well.  If you're not using these, and the latest kernel, please upgrade.
I'll leave it up to Dr. Mike wether or not to close the bug.  Seems
like there is more than one issue in this report now, so I would
recommend filling multiple reports.
Comment 12 Alexei Podtelezhnikov 2001-03-29 23:23:21 EST
1280 x 1024 x 24bpp  - i see the error messages.
1024 x  768 x 24bpp  - i see the error messages.
1280 x 1024 x 16bpp  - no more error messages.

Go figure...
I guess it has something to do with DRI problems at 24bpp. 
24 <-> 32 bpp conversions?
Comment 13 Mike A. Harris 2001-04-01 08:24:15 EDT

*** This bug has been marked as a duplicate of 26999 ***

Note You need to log in before you can comment on or make changes to this bug.