Bug 26999 - drm:r128_do_wait_for_fifo
drm:r128_do_wait_for_fifo
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 28987 42211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-10 19:04 EST by Gene Czarcinski
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 19:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/XFree86.0.log (27.52 KB, text/plain)
2001-02-12 21:10 EST, Gene Czarcinski
no flags Details
4.0.2-12.1 log file (26.08 KB, text/plain)
2001-03-10 13:17 EST, Gene Czarcinski
no flags Details
with XFree86, Mesa, and kernel-smp-2.4.2-0.1.25 (26.08 KB, text/plain)
2001-03-10 14:15 EST, Gene Czarcinski
no flags Details
with XFree86, Mesa, and kernel-smp-2.4.2-0.1.25 (3.03 KB, text/plain)
2001-03-10 14:15 EST, Gene Czarcinski
no flags Details
XFree86.0.log on 4.0.2a-1 (26.10 KB, text/plain)
2001-03-16 12:27 EST, Gene Czarcinski
no flags Details
rpm -qa | sort > installed-packages.txt (8.85 KB, text/plain)
2001-03-17 16:21 EST, Gene Czarcinski
no flags Details
uname -a (82 bytes, text/plain)
2001-03-17 16:21 EST, Gene Czarcinski
no flags Details
lspci -vn (2.13 KB, text/plain)
2001-03-17 16:22 EST, Gene Czarcinski
no flags Details
lspci -v (2.70 KB, text/plain)
2001-03-17 16:22 EST, Gene Czarcinski
no flags Details
/var/log/XFree86.0.log (52.48 KB, text/plain)
2001-03-31 13:48 EST, Gene Czarcinski
no flags Details
/etc/X11/XF86Config-4 (3.04 KB, text/plain)
2001-03-31 13:49 EST, Gene Czarcinski
no flags Details
rpm -qa | sort (8.51 KB, text/plain)
2001-03-31 13:50 EST, Gene Czarcinski
no flags Details
uname -a (82 bytes, text/plain)
2001-03-31 13:51 EST, Gene Czarcinski
no flags Details
lspci -vn (2.13 KB, text/plain)
2001-03-31 13:51 EST, Gene Czarcinski
no flags Details
lspci -v (2.70 KB, text/plain)
2001-03-31 13:52 EST, Gene Czarcinski
no flags Details
dual PIII 800MHz (764 bytes, text/plain)
2001-04-01 08:43 EDT, Gene Czarcinski
no flags Details
same behavior on single Athlon system (4.07 KB, text/plain)
2001-04-02 03:27 EDT, Alexei Podtelezhnikov
no flags Details
dmesg - same mistake along with "mtrr mismatch ..." (6.03 KB, text/plain)
2001-04-20 05:34 EDT, Alexei Podtelezhnikov
no flags Details
lspci -v output as requested (3.19 KB, text/plain)
2001-04-23 19:31 EDT, Derek Tattersall
no flags Details
XFree log as requested (incxludes reboot) (41.95 KB, text/plain)
2001-04-23 19:36 EDT, Derek Tattersall
no flags Details

  None (edit)
Description Gene Czarcinski 2001-02-10 19:04:13 EST
/var/log/messages is filling with messages:

 kernel: [drm:r128_do_wait_for_fifo] *ERROR* r128_do_wait_for_fifo failed!

video card is an ATI Rage 128
Comment 1 Mike A. Harris 2001-02-12 01:47:48 EST
Sent upstream, waiting for response.  Please attach Xserver log, messages
log, X configuration.
Comment 2 Gene Czarcinski 2001-02-12 21:10:00 EST
Created attachment 9863 [details]
/var/log/XFree86.0.log
Comment 3 Bill Nottingham 2001-03-09 11:32:38 EST
Does this work with 4.0.2-0.11 or later?
Comment 4 Gene Czarcinski 2001-03-09 16:02:59 EST
OK, looks like it is fixed.  I installed XFree86-4.0.2-11.4.0 and the messages
stopped.

I am still getting an occational message "drm:-r128_init] *ERROR* Cannot
initialize agpgart module." but otherwise it lloks good.

If acceptable , close this as appropriate.
Comment 5 Gene Czarcinski 2001-03-09 16:15:37 EST
Oops ... I misspoke.

I had XFree86 4.0.2-11 installed and the error was not occuring.  I just
installed 4.0.2-11.4.0 and the origianl error message is back ("...wait for fifo").

Comment 6 Mike A. Harris 2001-03-09 21:14:45 EST
Try the latest release please - XFree86-4.0.2-12.1 out located at:
ftp://people.redhat.com/mharris/xfree86

Also, make sure you have Mesa-3.4-10 installed, and you're using the
latest rawhide kernel.  You MUST use the latest kernel to get the r128
kernel fix.  If that doesn't work, please submit new log attachments,
and configs as well, and reopen the bug.
Comment 7 Gene Czarcinski 2001-03-10 13:16:14 EST
XFree86 4.0.2-12.1 and Mesa 3.4-10 now installed.

Problem is still there
Comment 8 Gene Czarcinski 2001-03-10 13:17:36 EST
Created attachment 12346 [details]
4.0.2-12.1 log file
Comment 9 Gene Czarcinski 2001-03-10 13:35:17 EST
Oops.  I missed the fact that I need to upgrade the kernel too.  Unfortunately,
rawhide on the ftp beta site is missing the kernel-smp for i686.  Since I do not
feel like rebuilding the kernel rpm right now, I will give the i586 package a try.
Comment 10 Gene Czarcinski 2001-03-10 14:13:11 EST
OK, I am running kernel-smp-242-0.1.25 (i586 rather than my usual i686) and
modutils-2.4.2-5.

Problem is still there.

I will attach the log and the/etc/X11/XF86Config-4 files.  Anything else?
Comment 11 Gene Czarcinski 2001-03-10 14:15:19 EST
Created attachment 12347 [details]
with XFree86, Mesa, and kernel-smp-2.4.2-0.1.25
Comment 12 Gene Czarcinski 2001-03-10 14:15:50 EST
Created attachment 12348 [details]
with XFree86, Mesa, and kernel-smp-2.4.2-0.1.25
Comment 13 Mike A. Harris 2001-03-15 15:17:39 EST
Fixed in 4.0.2a-1 in Rawhide
Comment 14 Gene Czarcinski 2001-03-16 12:25:49 EST
OK, I installed XFree86-4.0.2a-1 from the mharris directory on people.redhat.com
(and MEsa 3.4-12 from rawhide on the beta ftp).

Problem not fixed unfortunately.  I am still getting the messages in the log.

As before, this is running kernel-smp-2.4.2-0.1.25.

The XF86Config-4 has not changed.  I will attach the log.

Gene
Comment 15 Gene Czarcinski 2001-03-16 12:27:44 EST
Created attachment 12803 [details]
XFree86.0.log on 4.0.2a-1
Comment 16 Mike A. Harris 2001-03-17 14:52:17 EST
Boy, this one is really puzzling..  Can you run the following commands and
include file attachments of each of their outputs please?

rpm -qa | sort > installed-packages.txt
uname -a
lspci -vn
lspci -v

This _might_ be an smp specific issue.
Comment 17 Gene Czarcinski 2001-03-17 16:19:48 EST
I don't believe it is smp related.  I previously ran it with my up kernel and
still got the messages (the MB is still smp naturally).  I just ran it again and
still messages.  I did not run it long be did get the messages.  I notice that
lots of these messages occur in the middle of the night when xscreensaver is
running.

Attachments follow.
Comment 18 Gene Czarcinski 2001-03-17 16:21:05 EST
Created attachment 12885 [details]
rpm -qa | sort > installed-packages.txt
Comment 19 Gene Czarcinski 2001-03-17 16:21:38 EST
Created attachment 12886 [details]
uname -a
Comment 20 Gene Czarcinski 2001-03-17 16:22:05 EST
Created attachment 12887 [details]
lspci -vn
Comment 21 Gene Czarcinski 2001-03-17 16:22:27 EST
Created attachment 12888 [details]
lspci -v
Comment 22 Mike A. Harris 2001-03-18 13:36:41 EST
Ok, thanks for all the info.  My 4.0.3-1 release contains a patch for
this bug now.  Please try it out as it appears to solve the problem
during my testing.

XFree86-4.0.3-1 and Mesa-3.4-13 at ftp://people.redhat.com/mharris
Comment 23 Gene Czarcinski 2001-03-31 13:47:28 EST
qa0328 -- the problem is back and filling /var/log/mesages again.

I am attaching the usual set of files
Comment 24 Gene Czarcinski 2001-03-31 13:48:59 EST
Created attachment 14345 [details]
/var/log/XFree86.0.log
Comment 25 Gene Czarcinski 2001-03-31 13:49:54 EST
Created attachment 14346 [details]
/etc/X11/XF86Config-4
Comment 26 Gene Czarcinski 2001-03-31 13:50:34 EST
Created attachment 14347 [details]
rpm -qa | sort
Comment 27 Gene Czarcinski 2001-03-31 13:51:07 EST
Created attachment 14348 [details]
uname -a
Comment 28 Gene Czarcinski 2001-03-31 13:51:44 EST
Created attachment 14349 [details]
lspci -vn
Comment 29 Gene Czarcinski 2001-03-31 13:52:04 EST
Created attachment 14350 [details]
lspci -v
Comment 30 Mike A. Harris 2001-04-01 08:19:58 EDT
I think we're on to something here..  Attach me a copy of:

/proc/cpuinfo
Comment 31 Mike A. Harris 2001-04-01 08:24:11 EDT
*** Bug 28987 has been marked as a duplicate of this bug. ***
Comment 32 Gene Czarcinski 2001-04-01 08:43:42 EDT
Created attachment 14367 [details]
dual PIII 800MHz
Comment 33 Alexei Podtelezhnikov 2001-04-01 13:43:09 EDT
I, see bug 28987, see this messages with Athlon-750 with Rage 128 *PF*. 
Reducing color depth tp 16bpp didn't solve the problem, but messages are more 
rare: on X start-up, and once each time I run 3d screensaver. The do appear 
harmless though. I'll attack my logs later today.
Comment 34 Alexei Podtelezhnikov 2001-04-02 03:27:45 EDT
Created attachment 14423 [details]
same behavior on single Athlon system
Comment 35 Gene Czarcinski 2001-04-18 04:56:36 EDT
This is still occuring on 7.1 Gold.  Do you still need additional information?
Comment 36 Alexei Podtelezhnikov 2001-04-20 05:34:32 EDT
Created attachment 15864 [details]
dmesg - same mistake along with  "mtrr mismatch ..."
Comment 37 Derek Tattersall 2001-04-23 19:31:23 EDT
Created attachment 16165 [details]
lspci -v output as requested
Comment 38 Derek Tattersall 2001-04-23 19:36:01 EDT
Created attachment 16166 [details]
XFree log as requested (incxludes reboot)
Comment 39 Mike A. Harris 2001-05-15 05:50:08 EDT
Ok, it looks like our kernel was missing an additional patch that caused
several people to still experience this.  It is added into our current
kernel builds and will be released as an errata sometime in the near
future.
Comment 40 Alexei Podtelezhnikov 2001-05-16 02:55:44 EDT
Yes, kernel 2.4.3-5.i686 from rawhide fixed that for me.
Comment 41 Mike A. Harris 2001-05-25 07:10:16 EDT
*** Bug 42211 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.