Bug 290911 - debuginfo now has requirements on main package, makes installing it a PITA
debuginfo now has requirements on main package, makes installing it a PITA
Status: CLOSED DUPLICATE of bug 427579
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-14 10:52 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 21:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-09-14 10:52:24 EDT
Description of problem:

Current generated debuginfo packages have library requirements. This means
that they have implicit dependencies on quite possibly *ALL* subpackages built
from that source rpm.

Example:

# repoquery -C -q --repoid development-debuginfo --requires gcc-debuginfo
Running from cache, results might be incomplete.
libgcc_s.so.1()(64bit)
libgcj-tools.so.8rh()(64bit)
libgcj.so.8rh()(64bit)
libgcj_bc.so.1()(64bit)
libgcjwebplugin.so()(64bit)
libgfortran.so.1()(64bit)
libgij.so.8rh()(64bit)
libgjsmalsa.so()(64bit)
libgnarl-4.1.so()(64bit)
libgnat-4.1.so()(64bit)
libgomp.so.1()(64bit)
libgtkpeer.so()(64bit)
libjawt.so()(64bit)
libjvm.so()(64bit)
libmudflap.so.0()(64bit)
libmudflapth.so.0()(64bit)
libobjc.so.1()(64bit)
libstdc++.so.6()(64bit)

So, now if I want to install gcc-debuginfo, to debug something that uses libgcc,
I need to install objective C, gcj, mudflap, Ada, etc. This is a change from
prior releases.

Version-Release number of selected component (if applicable):

rpm-4.4.2.2-0.5.rc2
Comment 1 Panu Matilainen 2007-09-25 02:47:11 EDT
rpm's own debuginfo template has AutoReqProv:0 to disable this, but the version
in redhat-rpm-config doesn't. There's also god-knows-how-old comment in
redhat-rpm-config saying "NOTE: This is a copy from rpm to get the ifnarch
noarch fix, it can be removed later"

So maybe the fix is to finally remove the r-r-c debuginfo template, or add the
autoreqprov: 0 there too. Reassigning...
Comment 2 Adam Jackson 2007-10-05 11:59:14 EDT
You don't want to remove the r-r-c debuginfo template, as the one in base rpm
will name them -debug not -debuginfo.

The converse problem here is that debuginfo packages also have a useless (and
potentially huge) Provides list:

% rpm -q --provides java-1.7.0-icedtea-debuginfo-1.7.0.0-0.16.b19.snapshot.fc8
gcjwebplugin.so.debug()(64bit)  
libattach.so.debug()(64bit)  
libawt.so.debug()(64bit)  
libdcpr.so.debug()(64bit)  
libdt_socket.so.debug()(64bit)  
libfontmanager.so.debug()(64bit)  
libgctest.so.debug()(64bit)  
...

I'd happily fix this myself if someone would approve my acl on the debuginfo
package.
Comment 3 Christopher Beland 2008-02-26 23:12:12 EST
This looks like the same problem as Bug 427579, which has a fix posted.
Comment 4 Jon Masters 2008-04-25 21:54:58 EDT

*** This bug has been marked as a duplicate of 427579 ***

Note You need to log in before you can comment on or make changes to this bug.