Bug 427579 - debuginfo has invalid Requires
debuginfo has invalid Requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Masters
Fedora Extras Quality Assurance
: EasyFix, Patch
: 290911 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-04 16:19 EST by Jan Kratochvil
Modified: 2009-01-16 01:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 18:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix. (435 bytes, patch)
2008-01-04 16:19 EST, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2008-01-04 16:19:42 EST
Description of problem:
If you `yum install pkg-debuginfo' it will bring a lot of non-debuginfo packages
together.

Version-Release number of selected component (if applicable):
redhat-rpm-config-9.0.1-1.fc8.noarch

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -bb readline.spec
2. rpm -q -R -p /usr/src/redhat/RPMS/x86_64/readline-debuginfo-5.2-4.fc8.x86_64.rpm
  
Actual results:
Processing files: readline-debuginfo-5.2-4.fc8
Provides: libhistory.so.5.2.debug()(64bit) libreadline.so.5.2.debug()(64bit)
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libhistory.so.5()(64bit) libreadline.so.5()(64bit)

Expected results:
Processing files: readline-debuginfo-5.2-4.fc8
Provides: libhistory.so.5.2.debug()(64bit) libreadline.so.5.2.debug()(64bit)
Requires(rpmlib): rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

(no Requires, possibly also no Provides)

Additional info:
Fedora user complaint was here:
  https://www.redhat.com/archives/fedora-devel-list/2008-January/msg00342.html
Fix confirmation by Roland McGrath:
  https://www.redhat.com/archives/fedora-devel-list/2008-January/msg00362.html

/usr/lib/rpm/macros really already contains this fix:
#       Template for debug information sub-package.
%debug_package \
...
AutoReqProv: 0\
...
Comment 1 Jan Kratochvil 2008-01-04 16:19:42 EST
Created attachment 290860 [details]
Fix.
Comment 2 Christopher Beland 2008-02-26 23:06:28 EST
I had this problem today with openldap-debuginfo.  Is this fix going to make it
into Fedora 8?
Comment 3 Jan Kratochvil 2008-02-26 23:13:45 EST
(In reply to comment #2)
> I had this problem today with openldap-debuginfo.  Is this fix going to make it
> into Fedora 8?

It requires a mass-rebuild afterwards - it missed the F9 mass rebuild so it will
be fully fixed only in F10.
Comment 4 Jon Masters 2008-04-25 21:55:00 EDT
*** Bug 290911 has been marked as a duplicate of this bug. ***
Comment 5 Jon Masters 2008-05-06 18:49:29 EDT
I've checked the above fix into tomorrow's rawhide.
Comment 6 Christopher Beland 2008-11-01 22:47:42 EDT
I'm still seeing this problem in Fedora 10 Snap 3 with some packages.
For example, when I do "debuginfo-install `rpm -qa`", I get the following:

Installing for dependencies:
 gdk-pixbuf                     x86_64 1:0.22.0-36.fc9  rawhide           237 k
 gnome-mount-nautilus-properties
                                x86_64 0.8-1.fc9        rawhide            18 k
 gnumeric-plugins-extras        x86_64 1:1.8.2-2.fc9    rawhide            43 k
 libbeagle-python               x86_64 0.3.5-1.fc9      rawhide            22 k
 libieee1284-python             x86_64 0.2.11-3.fc9     rawhide            12 k
 libiptcdata-python             x86_64 1.0.2-2.fc9      rawhide            15 k
 lzo-minilzo                    x86_64 2.03-1.fc10      rawhide            12 k
 minizip                        x86_64 1.2.3-18.fc9     rawhide            24 k
 xmms                           x86_64 1:1.2.11-1.20071117cvs.1.fc10
                                                        rawhide           1.7 M
 xmms-libs                      x86_64 1:1.2.11-1.20071117cvs.1.fc10
                                                        rawhide           259 k
 xmms-xosd                      x86_64 2.2.14-11.fc9    rawhide            20 k
Comment 7 Christopher Beland 2009-01-16 01:27:14 EST
This seems to be better in Rawhide now, except for gnome-mount-nautilus-properties.  I've filed bug 480278 for that.

Note You need to log in before you can comment on or make changes to this bug.