Bug 29093 - Insmod of 3c90x gives Warning message
Summary: Insmod of 3c90x gives Warning message
Status: CLOSED DUPLICATE of bug 27412
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 17:10 UTC by Shane Painter
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 17:10:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Shane Painter 2001-02-23 17:10:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


When insmod of 3c90x driver with 3c980c-TC card is present, a warning is
posted to STDERR. 

root@64502.linuxdev.us.dell.com> insmod 3c90x
Using /lib/modules/2.4.1-0.1.9smp/kernel/drivers/net/3c90x.o
Warning: /lib/modules/2.4.1-0.1.9smp/kernel/drivers/net/3c90x.o parameter
switch delay has max < min.

Reproducible: Always
Steps to Reproduce:
1. Install Wolverine on a machine w/3c980c-TX
2. Insmod 3c90x.o
3. That's it.

Comment 1 Michael K. Johnson 2001-02-23 19:45:13 UTC
This bug has already been reported to 3com with no response.

*** This bug has been marked as a duplicate of 27412 ***

Comment 2 Sammy 2001-02-23 19:59:53 UTC
Well, I was the original poster of this bug....but after upgrading
my kernel (I built my own rpms, 2.4.1-ac20 + loop patches) and to
Wolverine the message stopped! I checked the 3c90x code and that
was still the same so something else has changed somewhere.

Comment 3 Michael K. Johnson 2001-02-23 21:02:13 UTC
The message was actually coming from modutils, not the module itself.
The module used a macro MAX_UNITS about a few thousand lines before
it was even defined; normally that would break compilation but
because the macro was only used with "stringification" it was actually
legal and became an empty string...  The switchdelay argument was marked
as having legal values between 1 and the empty string, which modutils
reasonably didn't like.

I have fixed that in our sources, but disabled it because of reports
of other problems and because it is superfluous in the face of the
existing and broader-scope 3c59x driver.


Note You need to log in before you can comment on or make changes to this bug.