Bug 29104 - iptables startup script contains unwanted lines
Summary: iptables startup script contains unwanted lines
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 29132 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 18:20 UTC by CoreDump
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 21:51:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CoreDump 2001-02-23 18:20:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


1. iptables stop contains a 'save' line which apparently results in a
./iptables: save: command not found
apparently save should be in a function outside the main script body

2. not everyone has mangle/nat tables, the script should check on
/proc/net/ip_tables_names first
Not only in 'for i in nat filter mangle' but everywhere throughout the
script


Reproducible: Always
Steps to Reproduce:
1./etc/init.d/iptables start

Comment 1 Preston Brown 2001-02-23 21:16:56 UTC
*** Bug 29132 has been marked as a duplicate of this bug. ***

Comment 2 Glen Foster 2001-02-23 21:51:34 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Bernhard Rosenkraenzer 2001-02-27 18:00:32 UTC
This was fixed in 1.2.0-8


Note You need to log in before you can comment on or make changes to this bug.