Bug 29132 - iptables-restore crashes or doesn't restore rule
Summary: iptables-restore crashes or doesn't restore rule
Status: CLOSED DUPLICATE of bug 29104
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-23 20:43 UTC by CoreDump
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 20:43:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description CoreDump 2001-02-23 20:43:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


1. iptables-restore dies if your /stc/sysconfig/iptables file isn't saved
with counters (lines starting with [).
2. iptables-restore can't restore some lines containing the keyword SYN (or
maybe iptables-save generates bad entry)


Reproducible: Always
Steps to Reproduce:
#iptables-restore
*filter
:INPUT DROP [34:10047]
-i lo -j ACCEPT 
^D


Actual Results:  Bad argument `EPT'


The bug sometimes causes segfault because strtok is called with NULL arg,
if the rule has no saved counters.

Comment 1 Preston Brown 2001-02-23 21:17:00 UTC

*** This bug has been marked as a duplicate of 29104 ***


Note You need to log in before you can comment on or make changes to this bug.