Bug 29138 - coral dumps core
coral dumps core
Status: CLOSED DUPLICATE of bug 28955
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-23 16:09 EST by Need Real Name
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 16:49:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-23 16:09:00 EST
coral dumps core in 
rpm -q xscreensaver
xscreensaver-3.25-4
gdb /usr/X11R6/lib/xscreensaver/coral core
...........
#0  0x400de706 in XrmQGetSearchResource () from /usr/X11R6/lib/libX11.so.6
(gdb) bt
#0  0x400de706 in XrmQGetSearchResource () from /usr/X11R6/lib/libX11.so.6
#1  0x400df01b in XrmQGetSearchResource () from /usr/X11R6/lib/libX11.so.6
#2  0x400df0f2 in XrmQGetResource () from /usr/X11R6/lib/libX11.so.6
#3  0x400df1e0 in XrmGetResource () from /usr/X11R6/lib/libX11.so.6
#4  0x804b1e4 in strcpy () at ../sysdeps/generic/strcpy.c:31
#5  0x804b575 in strcpy () at ../sysdeps/generic/strcpy.c:31
#6  0x8049db8 in strcpy () at ../sysdeps/generic/strcpy.c:31
#7  0x804a196 in strcpy () at ../sysdeps/generic/strcpy.c:31
#8  0x804b14e in strcpy () at ../sysdeps/generic/strcpy.c:31
#9  0x401bbf31 in __libc_start_main (main=0x804a9a0 <strcpy+4888>, argc=4, 
    ubp_av=0xbffffab4, init=0x8049188 <_init>, fini=0x804fb4c <_fini>, 
    rtld_fini=0x4000e274 <_dl_fini>, stack_end=0xbffffaac)
    at ../sysdeps/generic/libc-start.c:129
(gdb)
Comment 1 Bill Nottingham 2001-02-23 16:12:40 EST
Consistently, or occasionally?

Directly on startup, or after running for a while?

What X server are you using, at what bit depth?

Does it happen if you run it from the command line; if so, do you
need any special options?
Comment 2 Need Real Name 2001-02-23 16:49:21 EST
It after runninmg a while.
The 8bit 800x600
ls -lstr /etc/X11/X
   0 lrwxrwxrwx    1 root     root           29 Feb 19 13:19 /etc/X11/X ->
../../usr/X11R6/bin/XF86_SVGA
VGA compatible controller: Cirrus Logic GD 5434 (rev 195).
rpm -qa|grep XFree
XFree86-75dpi-fonts-4.0.1-1
XFree86-twm-4.0.1-1
XFree86-libs-4.0.1-1
XFree86-xfs-4.0.1-1
XFree86-4.0.1-1
XFree86-devel-4.0.1-1
XFree86-tools-4.0.1-1
XFree86-xdm-4.0.1-1
XFree86-SVGA-3.3.6-33

ls /etc/X11/XF86Config*
/etc/X11/XF86Config  /etc/X11/XF86Config-4
Device      "Cirrus Logic|GD 5434-8 [Alpine]"
    Monitor     "EIZO FlexScan T660"
    DefaultColorDepth   8
    Subsection "Display"
        Depth       8
        Modes       "800x600"
        ViewPort    0 0
    EndSubsection

--------------------------------

This is how I found these bugs in screensaver:
I checked several (3) RedHat 7.0 computers
and found a core file in home directory. of every computer.
then doing  strings core
found that every computer has a core dump of some screensaver process.

You can check RedHat 7.0 computers, I bet you found
a number of core files from screensaver process on them .

Also I just upgraded the screensaver to
rpm -q xscreensaver
xscreensaver-3.29-1

Let us see wheter the core files appear after a while
with new version.

Also because the screensaver dump core so often 
I would recommend to put into rpm a binaries without symbols stripping.
This will cost just few extra bytes, by would simplify the debugging a lot.
Comment 3 Bill Nottingham 2001-05-14 14:34:44 EDT

*** This bug has been marked as a duplicate of 28955 ***

Note You need to log in before you can comment on or make changes to this bug.