Bug 292661 - Anaconda fails to initialize swap ("busy" is sometimes given) every install attempt.
Anaconda fails to initialize swap ("busy" is sometimes given) every install a...
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: 295601 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-09-16 21:50 EDT by Bob Agel
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-17 21:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Agel 2007-09-16 21:50:17 EDT
Description of problem:
Anaconda fails to initialize swap and drops the install.

Version-Release number of selected component (if applicable):
Fedora8 T-2

How reproducible: Boot from Gnome Live CD and begin 'custom' install.  There are
two 80-gig HD's with install replacing T-1 on sda1, while swap is on sdb6. 
Partitions are:
sda1 - 18 gig Fedora8-T1
sda2 - 18 gig Linux Mint
sda3 - 18 gig open
balance of drive 'extended' & open

sdb1 - 15 gig Ubuntu
sdb2 - 20 gig Fedora7
sdb3 - 20 gig SAM linux
sdb4 - extended
sdb5 - 20 gig Debian
sdb6 - 1034meg swap

Steps to Reproduce:
1. Boot Live CD
2. Select Install From CD
Actual results: Failure due to swap (yes, I've tried formatting it as part of
the setup and it's recognized every time)

Expected results: Normal install as happened with T-1 and prior versions of
Fedora (all set up as ext3).

Additional info:
Comment 1 Jeremy Katz 2007-09-17 21:47:29 EDT
Fixed post-test2.  Run swapoff before the install for test2 (and noted in the
release notes for test2)
Comment 2 Bob Agel 2007-09-17 22:18:25 EDT
SOLVED: "Known Issues" lists solution. 
Comment 3 Jeremy Katz 2007-09-19 16:49:34 EDT
*** Bug 295601 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.