Bug 293241 - s-c-date traceback when choose GMT[+/-x] zones
s-c-date traceback when choose GMT[+/-x] zones
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 427177
  Show dependency treegraph
 
Reported: 2007-09-17 09:33 EDT by David Timms
Modified: 2008-01-01 19:20 EST (History)
0 users

See Also:
Fixed In Version: system-config-date-1.9.12-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:03:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some tracebacks as various GMT zones are clicked. (3.53 KB, text/plain)
2007-09-17 09:33 EDT, David Timms
no flags Details
Probably relates tracebacks since only occurs after selecting GMT zones (8.11 KB, text/plain)
2007-09-17 09:47 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2007-09-17 09:33:24 EDT
Description of problem:
Traceback possibly because instead being passed a lat/longitude combo, only a
latitude is set.

Version-Release number of selected component (if applicable):
system-config-date-1.9.0-1.fc7

How reproducible: Use following steps.

Steps to Reproduce:
1. start system-config-date from gnome-terminal
2. Time Zone tab
3. scroll to bottom of selected city pane
4. expand non-geographic-timezones
5. choose any of the GMT options.
  
Actual results:
1. Nothing seems to happen in the map, nor in the settings {but it might!}
2. A traceback appears on the terminal:
<GMT>
Traceback (most recent call last):
  File "/usr/share/system-config-date/timezone_map_gui.py", line 439, in
selectionChanged
    self.move_to (entry.long, entry.lat)
  File "/usr/share/system-config-date/timezone_map_gui.py", line 442, in move_to
    self.vp_set (long, lat)
  File "/usr/share/system-config-date/timezone_map_gui.py", line 375, in vp_set
    long += 180.0
TypeError: unsupported operand type(s) for +=: 'NoneType' and 'float'
* more attached.

Expected results:
Preferably map zooms fully out, and a longitudinal line or strip could be
highlighted based on the GMT offset, rather than a single dot.
Comment 1 David Timms 2007-09-17 09:33:24 EDT
Created attachment 197401 [details]
Some tracebacks as various GMT zones are clicked.
Comment 2 David Timms 2007-09-17 09:47:56 EDT
Created attachment 197431 [details]
Probably relates tracebacks since only occurs after selecting GMT zones

Once the original traceback has occurred, clicking either zoom-in/out, or the
slider causes additional different tracebacks - GarbageIGOut ?
Comment 3 Nils Philippsen 2007-10-09 11:03:25 EDT
I've fixed the traceback and will build a new version for Rawhide/Development
soon (which should find its way back to F7 after it got some testing), but
haven't implemented any graphical feedback like you suggested yet. I'll defer
this until after Fedora 8 is out, please reopen the bug then. Thanks.
Comment 4 Nils Philippsen 2007-10-09 12:27:17 EDT
system-config-date-1.9.12-1.fc8 fixes the traceback
Comment 5 David Timms 2008-01-01 19:03:38 EST
On F8 with system-config-date-1.9.16-1.fc8 on f8 or system-config-date-1.9.18-1.fc9:
- traceback in comment 0 and 1 no longer occur.
- the zoom in / out traceback while a GMT zone is selected still causes tb in #2


Note You need to log in before you can comment on or make changes to this bug.