Bug 29348 - After upgrade from RH6.x ntp ignores client requests on aliases interfaces
Summary: After upgrade from RH6.x ntp ignores client requests on aliases interfaces
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 41155 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-25 09:15 UTC by John Bass
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 08:15:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Bass 2001-02-25 09:15:33 UTC
Upgraded our primary gateway from RH6.1 to RH7.0 and nearly all client
systems are ignored. Starting up ntpd by hand with debug enabled promptly
explains the problem:

# ntpd -A -d -d -l /tmp/ntp
25 Feb 01:38:53 ntpd[28751]: logging to file /tmp/ntp
25 Feb 01:38:53 ntpd[28751]: ntpd 4.0.99j Wed Aug 23 13:11:23 EDT 2000 (1)
create_sockets(123)
interface <lo> OK
interface <eth0> OK
interface <eth1> OK
interface <eth1:0> ignored
interface <eth1:1> ignored
interface <eth1:2> ignored
interface <eth2> OK
interface <eth2:0> ignored
interface <eth2:1> ignored
interface <eth2:2> ignored
interface <eth2:3> ignored
interface <eth2:4> ignored
interface <eth2:5> ignored

All requests from those aliases are reported in the debug as received,
and are in fact ignored.

receive: at 93 xxx.xxx.xxx.xxx mode 3 code 2

The particular gateway routes for several bridged wireless networks
using several Class C's and partial Class C's. Aliased interfaces
are the only practical way to handle the mixture of subnets. It
doesn't make sense for ntp to ignore aliased interfaces - a very useful
feature.

Comment 1 John Bass 2001-02-28 11:09:19 UTC
After some additional source level debugging, enabling aliases with an
undocumented command line option "-L" didn't make a difference.

In searching the code, the problem appears not with aliases, but rather
that the requests are clasified as "code 2", aka AM_FXMIT, and discarded
in a switch statement for AM_FXMIT in ntp_proto.c

Client requests from most clients are tagged with this code, and their
requests are discarded without a response. Only requests from other servers
configured are processed.

It's not clear what additional options in /etc/ntp.conf are now required
to allow the local machine to be a server for local clients. In previous
releases, simply suppling a server directive with the address of a functional
ntp server in /etc/ntp.conf replacing the default local clock was enough.

Comment 2 Preston Brown 2001-03-05 15:52:27 UTC
you probably need to disable auth.

Comment 3 Harald Hoyer 2001-05-11 12:45:01 UTC
try to disable multicastclient or add multicast ability to the kernel


Comment 4 Harald Hoyer 2001-05-18 09:11:22 UTC
*** Bug 41155 has been marked as a duplicate of this bug. ***

Comment 5 Harald Hoyer 2001-09-04 09:20:23 UTC
could you please retry with ntp-4.1.0-3



Note You need to log in before you can comment on or make changes to this bug.