Bug 41155 - ntptrace timesout when tracing localhost or fqdn RH7+ ntpd
Summary: ntptrace timesout when tracing localhost or fqdn RH7+ ntpd
Status: CLOSED DUPLICATE of bug 29348
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-17 21:38 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-18 01:53:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-17 21:38:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
Since RH Version 7.0 ntptrace timesout when tracing my own ntpd and any 
other RH7+ active ntpd.  NTPD is active on all my systems and seems to 
keep the clock synced....   ntptrace failes to trace ANY RH7+ system.  I 
have ipchains active and logging but no packets are dropped.  It's like 
ntpd does not respond to ntptrace any more..

How reproducible:
Always

Steps to Reproduce:
1. edit /etc/ntpd.conf and add a time source
2. run /etc/rc.d/init.d/ntpd start
3. run ntptrace
	

Actual Results:  bash-2.04$ /usr/sbin/ntptrace
localhost.localdomain:  *Timeout*

OR

bash-2.04$ /usr/sbin/ntptrace 199.201.213.35
host:   *Timeout*    

Expected Results:  bash-2.04$ /usr/sbin/ntptrace 199.201.213.1
DS1.154.ALSV1 199.201.213.dynamic.net: stratum 4, offset 0.071681, synch 
distance 0.02748
border3.s6-2.dynamic-1.ocy.pnap.net: stratum 3, offset 0.001860, synch 
distance 0.03496
ns1.ocy.pnap.net: stratum 2, offset 0.001812, synch distance 0.03592
clock.isc.org: stratum 1, offset -0.001126, synch distance 0.00587, 
refid 'GOES'

Additional info:

ALL Redhat's less than 7.0 seem to work fine.

Comment 1 Need Real Name 2001-05-18 01:52:56 UTC
Also, you do have to wait until ntpd logs a sync loss message.  The message 
tells us that ntpd has actually become a sync server and is active.  This 
usually takes about 10 minutes.

Comment 2 Harald Hoyer 2001-05-18 09:11:27 UTC
try to disable multicastclient in /etc/ntpd.conf or add multicast ability to the kernel



*** This bug has been marked as a duplicate of 29348 ***


Note You need to log in before you can comment on or make changes to this bug.