Bug 293821 - Enhancement request: Dynamic Groups
Enhancement request: Dynamic Groups
Status: CLOSED DEFERRED
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
: 618988 637185 (view as bug list)
Depends On:
Blocks: 389_1.3.0 512820 690319
  Show dependency treegraph
 
Reported: 2007-09-17 15:47 EDT by Jeff Clowser
Modified: 2015-11-19 17:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 17:28:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Clowser 2007-09-17 15:47:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1)

Description of problem:
Would like to request a dynamic group functionality, similar to the dynamic group overlay functionality in OpenLDAP:

http://www.openldap.org/software/man.cgi?query=slapo-dynlist&apropos=0&sektion=0&manpath=OpenLDAP+2.3-Release&format=html

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Steps to Reproduce:
N/A - enhancement request

Actual Results:
N/A

Expected Results:
A method for creating dynamic groups where the entry returned has the group membership dynamically generated and returned as part of a list of dn's (i.e. fill in the uniquemember values) based on an LDAP URI (similar to groupofURLs, but have the server run the query instead of the client, and return the matches as part of the uniquemember attr - openldap actually offers more flexibility than this, but even supporting just ldap groups like this would be useful enough).

Additional info:
This is an enhancement request, not a bug.
Comment 4 Martin Kosek 2012-01-04 08:46:16 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/128
Comment 5 Rich Megginson 2012-01-06 11:59:15 EST
*** Bug 618988 has been marked as a duplicate of this bug. ***
Comment 6 Rich Megginson 2012-01-06 12:26:49 EST
*** Bug 637185 has been marked as a duplicate of this bug. ***
Comment 10 Noriko Hosoi 2015-11-19 17:28:54 EST
Closing this bug since we moved to the ticket system:
https://fedorahosted.org/389/ticket/128

Note You need to log in before you can comment on or make changes to this bug.