Bug 293861 - totem.desktop: include app name in Name=
totem.desktop: include app name in Name=
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
bzcl34nup
: Reopened
Depends On: 315221
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-09-17 15:59 EDT by Rex Dieter
Modified: 2009-03-04 20:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-04 19:45:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-09-17 15:59:14 EDT
Per discussion:
https://www.redhat.com/archives/fedora-devel-list/2007-September/msg01381.html

Please update .desktop files to include the name of the app in the Name=
field, ie,
totem.desktop to contain (something like):
Name=totem
GenericName=Movie Player
or
Name=totem Movie Player
(and not use GenericName at all)
Comment 1 Bastien Nocera 2007-09-17 16:08:54 EDT
That's wrong when the application is considered the "default" application, which
Totem is.

If you want this done properly, you should consider taking this upstream (ie. to
freedesktop).
Comment 2 Rex Dieter 2007-09-17 16:18:48 EDT
Did you read the fedora-devel thread?  It was (quasi) agreed this needs to be
fixed and cleaned up.

Besides, since you played the freedesktop "upstream" card, totem's .desktop file
isn't following the fdo desktop-entry-spec, that defines what
Name=,GenericName=,Comment= fields should contain,
https://www.redhat.com/archives/fedora-devel-list/2007-September/msg01372.html

or by upstream, did you mean http://www.gnome.org/projects/totem/ ?  (This
should be something easy enough for you to patch and push upstream).

Heck, I can provide the patch too if you want.
Comment 3 Bastien Nocera 2007-09-17 16:54:12 EDT
You can battle it out with Matthias if you want. The last changes regarding the
name in the .desktop file have been made for this bug:
http://bugzilla.gnome.org/show_bug.cgi?id=322162

AFAIK, GenericName isn't used in gnome-menus/gnome-panel, and changing the Name=
would mean obsoleting 77 translations, which is absolutely out of question.


(In reply to comment #2)
> Did you read the fedora-devel thread?  It was (quasi) agreed this needs to be
> fixed and cleaned up.

The only thing I can see is people not agreeing on the way it should be done.

> Besides, since you played the freedesktop "upstream" card, totem's .desktop file
> isn't following the fdo desktop-entry-spec, that defines what
> Name=,GenericName=,Comment= fields should contain,
> https://www.redhat.com/archives/fedora-devel-list/2007-September/msg01372.html

Which GNOME doesn't implement/can't implement properly.

> or by upstream, did you mean http://www.gnome.org/projects/totem/ ?  (This
> should be something easy enough for you to patch and push upstream).

Is "ie. to freedesktop" not clear?

> Heck, I can provide the patch too if you want.

If only it were correct. All I can see is that nothing's been agreed in the
thread, other than mentions of rogue applications not following the "default"
name convention.
Comment 4 Kevin Kofler 2007-09-17 20:36:07 EDT
> AFAIK, GenericName isn't used in gnome-menus/gnome-panel, and changing the
> Name= would mean obsoleting 77 translations, which is absolutely out of
> question.

For F8 maybe (string freeze), but for F9 and beyond?
Comment 5 Bug Zapper 2008-04-04 09:51:37 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Nils Philippsen 2008-04-04 11:53:20 EDT
Still present in (pre-)F9, totem-2.23.0-6.fc9.
Comment 7 Bug Zapper 2008-05-13 23:14:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Rex Dieter 2009-03-04 20:06:42 EST
Upstream is better I guess, having applications not identifying themselves clearly via it's .desktop file is unfortunate.

Note You need to log in before you can comment on or make changes to this bug.