Bug 315221 - decide if we want to continue using Generic Names for major applications, or revert to each apps upstream Name
decide if we want to continue using Generic Names for major applications, or ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Bill Nottingham
:
Depends On: 293781
Blocks: F9Target 293771 293791 293841 293851 293861
  Show dependency treegraph
 
Reported: 2007-10-02 07:02 EDT by Caolan McNamara
Modified: 2014-03-16 23:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-27 05:48:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2007-10-02 07:02:04 EDT
Description of problem:

Per discussion:
https://www.redhat.com/archives/fedora-devel-list/2007-September/msg01381.html

"Please update .desktop files to include the name of the app in the Name=
field, ie,
openoffice.org-1.9-writer.desktop to contain (something like):
Name=openoffice.org writer
GenericName=Word Processor
or
Name=openoffice.org Word Processor"

and similar for other major top level "best of breed" applications.

We deliberately did this change as part of selecting what we felt to be the best
default choice for applications in every given niche to make it easy for a user
unfamiliar with all the various application names to find a useful app.

Do we want to continue with this, or revert to the upstream names, or do
something else entirely. It doesn't make sense to revert some apps, and not others
Comment 1 Kevin Kofler 2007-10-02 07:18:42 EDT
As discussed on the mailing list, the main problem is that there's no one 
default application for a given task anymore now that there's the KDE spin too. 
While in principle "best of breed" sounds like a good idea, in practice the 
choices are heavily biased towards GNOME applications, and the KDE spin 
defaults to the KDE equivalents instead. (While OO.o is technically not a GNOME 
app, the KDE spin also has a different default, namely KOffice, there.) If the 
KDE spin follows your same logic, users installing apps from both spins (which 
is more frequent than you might think) will end up with 2 "E-Mail" menu items, 
2 "Word Processor"s, 2 "IRC" items etc. and will have a really hard time 
knowing which is which.

Compliance with the freedesktop.org spec is another good reason which was given 
on the mailing list.

I thought the consensus on the mailing list was pretty clear, this needs to 
change. Do we really have to rehash this discussion in this bug report?

As for the "to make it easy for a user unfamiliar with all the various 
application names to find a useful app" argument, that doesn't make sense if we 
go the "Name=openoffice.org Word Processor" route. That's not my favorite 
choice (I think we should follow the freedesktop.org spec completely and use 
Name and GenericName), but it works around the issue of GNOME ignoring 
GenericName.
Comment 2 Caolan McNamara 2007-10-02 08:07:26 EDT
I don't mind sticking whatever the agreed text is into the .desktop files, but I
don't think it's at all clear what the consensus/desired solution is.
Comment 3 Kevin Kofler 2007-10-31 19:51:37 EDT
Is there any chance we can agree on this or do you want this to be ruled on by 
FPC or some other committee?
Comment 4 Matthias Clasen 2008-02-05 11:53:16 EST
I've stated my opinion on this here:

https://www.redhat.com/archives/fedora-devel-list/2007-December/msg00885.html
Comment 5 Bug Zapper 2008-05-13 23:18:57 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Kevin Kofler 2008-08-27 05:52:35 EDT
What's the resolution leading to this being closed?
Comment 7 Caolan McNamara 2009-03-19 09:37:10 EDT
to clear the "need-info" flag re "why was it closed": because I went with the consensus and these days the OOo apps are called "OpenOffice.org Writer" and Firefox is "Firefox Web Browser" in the desktop menus
Comment 8 Kevin Kofler 2009-03-19 13:23:59 EDT
So this means I won't get killed if I (in my position as comaintainer of xchat) change XChat's "Name=IRC" to "Name=XChat IRC"?
Comment 9 Matthias Clasen 2009-03-19 14:43:15 EDT
Unfortunately, 'XChat IRC' is in no way better than 'IRC'. 
Unless you consider 2 incomprehensible terms > 1 incomprehensible term, that is.
Comment 10 Kevin Kofler 2009-03-19 14:56:39 EDT
Well, then why is the current name "IRC"?

I think "XChat IRC" is better because:
* it contains the word "chat" which is certainly more meaningful to new users than the "IRC" acronym and
* (IMHO most importantly) experienced users get to know which client is being run.

Note You need to log in before you can comment on or make changes to this bug.