Bug 29488 - Netscape crash when selecting addressbook entry
Summary: Netscape crash when selecting addressbook entry
Status: CLOSED DUPLICATE of bug 10433
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-26 00:08 UTC by Stephen R. Donaldson
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-26 00:08:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen R. Donaldson 2001-02-26 00:08:56 UTC
After importing an address book exported from Netscape 4.61 (which may
have nothing to do with the problem, as I had done nothing before that):
 
I got the same problem with the Netscape on the RH7.0 CDs, then got the
later RPMs from Redhat (4.76).  Still get a SIGBUS/SIGSEGV when doing
the following:
 
From Messenger->New Msg->address; highlight address; then select "To:" and
seg violation.
 
Additionally, the processor is a 1.2GHz AMD Athlon.

Program received signal SIGSEGV, Segmentation fault.
strcpy (dest=0x8d64d00 "", src=0x0) at ../sysdeps/generic/strcpy.c:39
39      ../sysdeps/generic/strcpy.c: No such file or directory.
(gdb) where
#0  strcpy (dest=0x8d64d00 "", src=0x0) at ../sysdeps/generic/strcpy.c:39
#1  0x836b1cf in XFE_AddresseeView::getColumnText ()
#2  0x8360a28 in XFE_Outliner::contentCellDraw ()
#3  0x8360e85 in XFE_Outliner::celldraw ()
#4  0x8361922 in XFE_Outliner::celldrawCallback ()
#5  0x40033778 in XtCallCallbackList () from /usr/X11R6/lib/libXt.so.6
#6  0x8391c55 in XmLFolderSetActiveTab ()
#7  0x4003f3e5 in _XtEventInitialize () from /usr/X11R6/lib/libXt.so.6
#8  0x4003f147 in XtDispatchEventToWidget () from /usr/X11R6/lib/libXt.so.6
#9  0x4003ecf0 in XtDispatchEventToWidget () from /usr/X11R6/lib/libXt.so.6
#10 0x4003f820 in _XtOnGrabList () from /usr/X11R6/lib/libXt.so.6
#11 0x4003fb99 in XtDispatchEvent () from /usr/X11R6/lib/libXt.so.6
#12 0x4004aa3e in XtAppProcessEvent () from /usr/X11R6/lib/libXt.so.6
#13 0x82bd5ad in fe_EventLoop ()
#14 0x82bffc5 in main ()
#15 0x40215b65 in __libc_start_main (main=0x82be7a4 <main>, argc=2,
    ubp_av=0xbffffd54, init=0x827f548 <_init>, fini=0x894914c <_fini>,
    rtld_fini=0x4000df24 <_dl_fini>, stack_end=0xbffffd4c)
    at ../sysdeps/generic/libc-start.c:111
(gdb)

Comment 1 Bill Nottingham 2001-02-26 00:14:42 UTC

*** This bug has been marked as a duplicate of 10433 ***


Note You need to log in before you can comment on or make changes to this bug.