Bug 29499 - [promise] ATA-66 controller halts kernel (Promise Tech)
[promise] ATA-66 controller halts kernel (Promise Tech)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben LaHaise
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 21:27 EST by harry.heinisch
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 11:37:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description harry.heinisch 2001-02-25 21:27:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)


If disks are hung off the Promise Technologies controller (Quantum 
Fireball - ATA-66 or IBM Deskstor - ATA-100) kernel dies after reporting 
IRQs for controllers

Reproducible: Always
Steps to Reproduce:
1.Boot off install disk (disk 1 of 2)
2.Wait to see kernel lock on first screen of data
3.
	

Actual Results:  Kernel locks machine

Expected Results:  Kernel proceeds with install

If disks are disconnected from controller, system will start installer 
(without any media to install to).
Comment 1 Glen Foster 2001-02-26 18:12:16 EST

*** This bug has been marked as a duplicate of 29427 ***
Comment 2 Michael K. Johnson 2001-02-27 09:51:49 EST
This does not look like a duplicate of 29427; in that one, the install
fails; here boot fails after irq probing.  While they may be related,
it is not at all certain that they are.

Is this an SMP or uniprocessor system?
Comment 3 Ben Levenson 2001-02-28 14:49:12 EST
build: Wolverine and qa0228.0
performed several tests with the Promise controller:
Installations completed successfully with devices attached to 
ATA100-primary (hard drive (hde)) and ATA-100-secondary (cdrom (hdh)); 
and with devices on ATA100-primary (hard drive (hde)) and IDE-primary 
(cdrom (hdb)).
No kernel hangs when booting the install kernel or the post-install kernel.
see but #29427 for more details: 
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=29427
Comment 4 harry.heinisch 2001-03-01 20:48:57 EST
This system is a uni-proc with a PDC20262. Drives as seen by kernel are hde 
(ATA-66 Quantum Fireball) and hdf (ATA-100 IBM Destor). Looked at bug #29427, 
but cannot get past kernel boot into installer.
Comment 5 Arjan van de Ven 2001-03-19 10:48:23 EST
1) Are you using the proper 80 ribbon cable
2) Does booting with "ide=nodma" on the qa0309 snapshot work ?
Comment 6 Michael K. Johnson 2001-07-03 15:48:51 EDT
Closing, assumed fixed in released product because of lack of further complaint.
Please reopen this bug report with the requested information if you are still
experiencing this problem.

Note You need to log in before you can comment on or make changes to this bug.