Bug 29427 - installation oopsing on badblock checks
installation oopsing on badblock checks
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 29472 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-25 14:42 EST by Michal Jaegermann
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 10:22:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog file saved from a failed installation attempt (4.06 KB, application/octet-stream)
2001-02-25 14:43 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2001-02-25 14:42:33 EST
A Wolverine installer dies in many interesting ways if one tries to turn 
on bad blocks checking; at least on a machine with PDC20265 controller.
Effects vary - I got an instant spontaneous reboot, a backtrace from
anaconda which, unfortunately, I could not save to a floppy as 
everything just died and attempt to repeat failed, just a silent
lockup...  You name it.

On one occasion I was left with enough of shell to be able to save
/tmp/syslog file to a floppy.  It is attached to this report.

BTW - using a boot floppy made from a boot.img from Wolverine and
RH7 CD for starting an installation has the same effects.

Note: the machine on which this behaviour was observed is not mine
and pretty soon I may not have an access to it. :-(

  Michal
  michal@harddata.com
Comment 1 Michal Jaegermann 2001-02-25 14:43:59 EST
Created attachment 11040 [details]
syslog file saved from a failed installation attempt
Comment 2 Michael Fulbright 2001-02-25 23:14:18 EST
What is a PDC20265 controller?
Comment 3 Michal Jaegermann 2001-02-25 23:28:21 EST
> What is a PDC20265 controller?

IDE multichannel controller from Promise.  See also #29472 and #29508.
Here is 'lspci -vv' output for this device:
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20265 (rev 02)
        Subsystem: Promise Technology, Inc.: Unknown device 4d33
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at 8000 [size=8]
        Region 1: I/O ports at 7800 [size=4]
        Region 2: I/O ports at 7400 [size=8]
        Region 3: I/O ports at 7000 [size=4]
        Region 4: I/O ports at 6800 [size=64]
        Region 5: Memory at d9000000 (32-bit, non-prefetchable) [size=128K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [58] Power Management version 1
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


Comment 4 Glen Foster 2001-02-26 18:09:46 EST
*** Bug 29472 has been marked as a duplicate of this bug. ***
Comment 5 Glen Foster 2001-02-26 18:12:12 EST
*** Bug 29499 has been marked as a duplicate of this bug. ***
Comment 6 Glen Foster 2001-02-26 18:54:49 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 7 Michael Fulbright 2001-02-26 21:28:02 EST
I have an Asus A7V motherboard with the same Promise controller and I've had no
problems installing and using it as my test machine for anaconda development.

What brand motherboard do you have, and what version of the BIOS are you running?
Comment 8 Michal Jaegermann 2001-02-26 22:47:13 EST
It is Asus A7V (small world) with Award ACPI BIOS 1005C.  Which BIOS version
you are using?
Comment 9 Michal Jaegermann 2001-02-27 10:53:24 EST
Here are reports which seems to be related to what I am seeing:
http://www.uwsg.indiana.edu/hypermail/linux/kernel/0102.2/0888.html
http://www.uwsg.indiana.edu/hypermail/linux/kernel/0102.3/0022.html
Comment 10 Michael Fulbright 2001-02-27 18:26:26 EST
Will try with the latest BIOS, I have 1004D.
Comment 11 Ben Levenson 2001-02-28 13:54:30 EST
BUILD: Wolverine AND qa0228.0

HARDWARE: ASUS A7V --Promise PDC20265 controller--Maxtor 53073UG (30Gig)
and CDROM

BIOS: Award ACPI Rev. 1005C

lspci -v:
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20265 (rev
02)
        Subsystem: Promise Technology, Inc.: Unknown device 4d33
        Flags: bus master, medium devsel, latency 32, IRQ 10
        I/O ports at 9000 [size=8]
        I/O ports at 8800 [size=4]
        I/O ports at 8400 [size=8]
        I/O ports at 8000 [size=4]
        I/O ports at 7800 [size=64]
        Memory at e1000000 (32-bit, non-prefetchable) [size=128K]
        Expansion ROM at <unassigned> [disabled] [size=64K]
        Capabilities: [58] Power Management version 1
Performed:
NFS-Custom w/ bad block check -- completed successfully
post-install -- OK
GUI-CDROM w/ bad block check -- completed successfully
post-install -- OK
Configurations:
Installations completed successfully with devices attached to 
ATA100-primary (hd) and ATA-100-secondary (cdrom); 
and with devices on ATA100-primary (hd) and IDE-primary (cdrom).
Comment 12 Michal Jaegermann 2001-02-28 15:30:18 EST
Please check my latest comments to #29508.  I still have to check the
whole installation but this may be it.
Comment 13 Michael Fulbright 2001-03-01 14:19:29 EST
Adding Bob to CC list since he's investigating Promise problems.
Comment 14 Bob Matthews 2001-03-02 09:53:32 EST
Arjan and I have been working with the settings on these motherboards trying to
determine the cause of the problem.  Here's what we've come up with:

V = (PCI Dram Master Pipeline Request, Enhanced CPU to PCI Write, PCI Burst,
Post Write Retry Fail)

V = 1101, default settings in BIOS v. 1003, 1004, 1004D, fails with FS errors.  
    1100, FS errors
    1011, FS errors
    0101, FS errors
    0010, no FS errors

So, it is some combination of settings which is causing the problems, but we
know a setting which appears to work.
Comment 15 Michal Jaegermann 2001-03-04 19:54:19 EST
Few days ago a new BIOS version 1007 showed up. Unfortunately I do not see
much difference after an update (with an exception that with a new BIOS
if "System Performance" is set to "Normal" then BIOS also displays "Normal"
and not "Optimal" like with 1005C).  Still with an "Optimal" setting a system
disintegrates after a short while in many interesting ways.  OTOH with "Normal",
and with "Legacy USB support" turned off, I went through roughly 40 GB worth
of disk with 'badblocks' checks and it passed.
Comment 16 Bob Matthews 2001-03-07 10:22:16 EST
The via-corruption patch in kernel 0.1.21 has fixed this problem.  The machine
ran a minimal Cerberus test (including all the FS tests) with no corruption.

Note You need to log in before you can comment on or make changes to this bug.