This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 295371 - gtkimmodules no longer multilib
gtkimmodules no longer multilib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mash (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-09-18 15:35 EDT by Warren Togami
Modified: 2014-03-16 23:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 15:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mash-multilib-gtkimm.patch (577 bytes, patch)
2007-09-20 00:31 EDT, Jens Petersen
no flags Details | Diff

  None (edit)
Description Warren Togami 2007-09-18 15:35:01 EDT
In Bug #295331 it was noticed that F8 is using XIM instead of scim-bridge as the
default gtkimm.  Is this a bug?
Comment 1 Jens Petersen 2007-09-19 01:14:12 EDT
Warren, what did you install? :)

Easiest way to get lang/input support for Japanese in F8 say is to groupinstall
japanese-support or install scim-lang-japanese, and then currently to use
im-chooser if your desktop in a non-Asian locale.
Comment 2 Warren Togami 2007-09-19 12:12:58 EDT
I started with an English-only install of F8, then used:
yum groupinstall japanese-support korean-support chinese-support
Comment 3 Warren Togami 2007-09-19 18:10:58 EDT
[warren@newcaprica ~]$ rpm -qa 'scim*'
scim-bridge-0.4.13-4.fc8
scim-tables-chinese-0.5.7-3.fc7
scim-libs-1.4.7-4.fc8
scim-hangul-0.3.1-1.fc7
scim-pinyin-0.5.91-20.fc8
scim-lang-japanese-1.4.7-4.fc8
scim-anthy-1.2.4-2.fc8
scim-tables-0.5.7-3.fc7
scim-chewing-0.3.1-9.fc7
scim-lang-korean-1.4.7-4.fc8
scim-bridge-gtk-0.4.13-4.fc8
scim-lang-chinese-1.4.7-4.fc8
scim-1.4.7-4.fc8

Not sure if this is related... but...
System menu > Personal > Input Method
"Use SCIM (Legacy)"

Is this normal?  Why does it say Legacy?
Comment 4 Jens Petersen 2007-09-20 00:04:47 EDT
I'm guessing you're on a multilib box?

and oops scim-bridge-gtk is not multilib anymore in rawhide... :-(

Thanks for reporting this.

> Why does it say Legacy?

Because it fell back to XIM to avoid having broken multilib gtkimm.
Comment 5 Jens Petersen 2007-09-20 00:10:10 EDT
Jesse, can we please make scim-bridge-gtk multilib again?
Comment 6 Jens Petersen 2007-09-20 00:31:12 EDT
Created attachment 200441 [details]
mash-multilib-gtkimm.patch

Warren pointed me at mash and I found this typo.
Comment 7 Jesse Keating 2007-09-20 09:49:54 EDT
Committed.

Bill can you do a build?
Comment 8 Bill Nottingham 2007-09-20 15:22:59 EDT
Fixed in 0.2.6.

Note You need to log in before you can comment on or make changes to this bug.