Bug 295331 - Return does not work with XIM
Return does not work with XIM
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
: i18n, Reopened
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-18 14:59 EDT by Warren Togami
Modified: 2008-02-11 14:22 EST (History)
8 users (show)

See Also:
Fixed In Version: 2.8.4-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 20:39:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-09-18 14:59:26 EDT
Bug #224180 xchat was upgraded.  This upgrade broke input methods.  We really
have to fix this before F8 and in F7 updates soon.
Comment 1 Warren Togami 2007-09-18 15:21:09 EDT
--enable-spell=none
--enable-spell=static

Tried building with these options, they no longer fix the problem.  Seems that
upstream made it worse. =(
Comment 2 Warren Togami 2007-09-18 15:21:50 EDT
Adding i18n group.  They might be interested in knowing that IM is broken in
xchat in both F7 and F8.
Comment 3 Kevin Kofler 2007-09-18 15:26:59 EDT
CCing upstream too.

From https://bugzilla.redhat.com/process_bug.cgi#c16 :
I had the update tested by someone using the Korean SCIM input method and it 
worked for him. (He just tried again with 2.8.4-2.fc7 and it still works for 
him.) I wouldn't have pushed it otherwise. So "completely" is probably the 
wrong word, still this doesn't sound good. Does this break only some input 
methods and not others?
Comment 4 Warren Togami 2007-09-18 15:33:09 EDT
Interesting... something else weird is going on.

/desktop/gnome/interface/show_input_method_menu
Set this to on in order to see and change the current IM setting.

Starting GTK+ apps in F8 defaults with "X Input Method" instead of "SCIM Bridge
Input Method".  If you manually select the latter, then xchat works as expected.

There might actually be two bugs going on here:
1) GNOME or GTK+ isn't using scim-bridge by default on F8.
2) xchat is broken with XIM specifically.

#2 is quite bad itself.
Comment 5 Warren Togami 2007-09-18 15:35:34 EDT
scim-bridge problem filed in Bug #295371.
Comment 6 Kevin Kofler 2007-09-20 03:42:07 EDT
Is this really a high-priority F8Blocker now that things are being fixed so 
SCIM is picked by default again? Isn't XIM obsolescent anyway?

I'm not saying it shouldn't be fixed, but I'm wondering how urgent this really 
is.
Comment 7 Warren Togami 2007-09-20 12:45:53 EDT
Downgrading to F8Target.
Comment 8 Peter Zelezny 2007-09-20 21:44:55 EDT
I don't know enough about IMs to help much, but it's probably related to:

http://sf.net/tracker/index.php?func=detail&aid=896968&group_id=239&atid=100239
Comment 9 Jens Petersen 2007-09-24 23:30:05 EDT
I just tried with current rawhide and I can use scim ok in xchat.

Is this ok now?
Comment 10 Kevin Kofler 2007-09-25 00:50:18 EDT
See Warren's comment #4, SCIM works, XIM doesn't. (I haven't confirmed this 
myself though.)
Comment 11 Jens Petersen 2007-09-25 01:03:39 EDT
Ah, yes - XIM looks ok to me too though.
Comment 12 Warren Togami 2007-09-25 02:44:48 EDT
No, still broken.

Procedure
=========
1) LANG=en_US.UTF-8 xchat
2) Right-click in the text entry box, switch to X Input Method
3) Type a line
4) Hit ENTER
5) ENTER didn't happen.
Comment 13 Jens Petersen 2007-09-25 02:54:12 EDT
Ok.  How about with "GTK_IM_MODULE=xim xchat"?

That seems to work for me.
Comment 14 Jens Petersen 2007-10-11 01:47:35 EDT
Ah I see what you mean: reproduced completely.

Please ignore comment 13.

Anyway I suspect input is broken with XIM anyway so probably
not a good idea to use it with xchat currently, but that
doesn't help users using xim only input methods of course...
Comment 15 Peng Huang 2007-10-12 06:19:44 EDT
I found xchat-2.4.3-im_context_filter_keypress.patch causes this problem. What
is this patch for? It seems that this patch is for xchat-2.4.3. Maybe we could
drop it now.
Comment 16 Peng Huang 2007-10-12 06:24:19 EDT
I also found xchat-2.4.4-unrealize.patch can be dropped too. This patch has been
committed to. I think we should review every old patches now!
Comment 17 Peng Huang 2007-10-12 06:27:42 EDT
(In reply to comment #16)
> I also found xchat-2.4.4-unrealize.patch can be dropped too. This patch has been
> committed to upstream. I think we should review every old patches now!
             ~~~~~~~~~~
Sorry for typo. :P

Comment 18 Akira TAGOH 2007-10-12 06:51:44 EDT
(In reply to comment #15)
> I found xchat-2.4.3-im_context_filter_keypress.patch causes this problem. What
> is this patch for? It seems that this patch is for xchat-2.4.3. Maybe we could
> drop it now.

See Bug#144588. it might be applied wrongly because it was made for the older
release. please make sure if xchat without that patch works now for #144588 too.
Comment 19 Kevin Kofler 2007-10-12 09:01:05 EDT
I'll drop xchat-2.4.4-unrealize.patch, it's indeed obsolete, though having it 
applied a second time should be harmless in that case.

As for xchat-2.4.3-im_context_filter_keypress.patch: I see there's a return 
breaking out of a while loop. Can one of you test what happens if you change 
the return TRUE; in the patch to a continue;?
Comment 20 Kevin Kofler 2007-10-12 09:04:10 EDT
Uh, just a continue won't work, because it would also skip the move to the next 
key:
		last = kb;
		kb = kb->next;
I'm also not sure it's the right thing to do anyway.
Comment 21 Kevin Kofler 2007-10-12 09:14:36 EDT
I don't think the patch is being wrongly applied, I looked at the history of 
fkeys.c in the XChat CVS and I don't see anything changed in the context of the 
patch.
Comment 22 Peng Huang 2007-10-12 09:37:33 EDT
(In reply to comment #18)

> 
> See Bug#144588. it might be applied wrongly because it was made for the older
> release. please make sure if xchat without that patch works now for #144588 too.
> 
We don't use iiimf now. I can not reproduce this problem. It seems work fine
with SCIM.
Comment 23 Kevin Kofler 2007-10-12 09:43:13 EDT
And XIM? (I know it's not the default, but breaking one thing for XIM while 
fixing another would be bad. ;-) )
Comment 24 Kevin Kofler 2007-10-12 20:26:42 EDT
I'm going ahead and killing the broken 
xchat-2.4.3-im_context_filter_keypress.patch, because the patch apparently 
breaks more than it fixes when applied to the current XChat.
Comment 25 Fedora Update System 2007-11-09 18:48:26 EST
xchat-2.8.4-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'
Comment 26 Fedora Update System 2007-11-28 20:39:22 EST
xchat-2.8.4-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Dominik 'Rathann' Mierzejewski 2007-12-01 06:28:46 EST
2.8.4-6.fc7 breaks scim-anthy for me. I could correct the
converted-but-not-committed string with cursor keys (up/down) before, but now,
if I press up or down I just move backward or forward in irc input history. This
needs to be fixed, please. Return key worked fine before, too.
Comment 28 Kevin Kofler 2007-12-01 13:17:46 EST
Hmmm, the update has been in Rawhide for over a month, in F8 since its release 
and in F7 updates-testing for almost a month and it's now that the problem 
reports show up? :-( I don't blame you in particular, I know you may be too 
busy or lack the hardware to test updates-testing and/or Rawhide, but the 
general lack of testers.

All I can offer to you for now is to reinstall 2.8.4-5.fc7 with 
rpm -Uvh --oldpackage. (You know where to get it from, right?) I hope we can 
make a working im_context_filter_keypress patch (i.e. one which fixes this 
without breaking XIM again) as soon as possible. I'd really appreciate any help 
I can get from the RH i18n team there.
Comment 29 Dominik 'Rathann' Mierzejewski 2007-12-01 15:56:35 EST
Well it's not your fault, either. It's my fault for not following
updates-testing. :) I just thought you should know. It's been confirmed by one
of my friends on IRC, too. Feel free to let me know if you have something new to
test regarding this issue.
Comment 30 Jens Petersen 2008-02-06 23:53:46 EST
(In reply to comment #27)
> 2.8.4-6.fc7 breaks scim-anthy for me. I could correct the
> converted-but-not-committed string with cursor keys (up/down) before, but now,
> if I press up or down I just move backward or forward in irc input history.
> This needs to be fixed, please. Return key worked fine before, too.

I just tried with 2.8.4-11.fc9 in rawhide with scim-bridge and that works fine.
Which immodule are you using?
Comment 31 Kevin Kofler 2008-02-07 00:01:17 EST
He already said it, it's scim-anthy:
> 2.8.4-6.fc7 breaks scim-anthy for me.
Comment 32 Jens Petersen 2008-02-07 00:19:13 EST
(In reply to comment #31)
> He already said it, it's scim-anthy:

scim-anthy is IMEngine used by scim.
I am testing with that too.
Comment 33 Dominik 'Rathann' Mierzejewski 2008-02-11 14:22:22 EST
2.8.4-11 is still broken, but differently:
I still can't choose between various anthy's matches using up/down, but it I
don't move backward or forward in irc input history anymore when in anthy mode.

I think we should move this discussion to the bug report I've opened
specifically for this new issue: bug 429104.

Note You need to log in before you can comment on or make changes to this bug.