Bug 296021 - Anaconda crashes removing an activated swap LV (LiveCD)
Anaconda crashes removing an activated swap LV (LiveCD)
Status: CLOSED DUPLICATE of bug 295601
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 05:17 EDT by Àlex Magaz Graça
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 09:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash dump (21.18 KB, text/plain)
2007-09-19 05:17 EDT, Àlex Magaz Graça
no flags Details

  None (edit)
Description Àlex Magaz Graça 2007-09-19 05:17:10 EDT
Description of problem:

Installing from a LiveCD with a swap LVM partition activated makes anaconda
crash when trying to remove the LV.

Version-Release number of selected component (if applicable):
anaconda 11.2.0.66-1
LiveCD created with pilgrim from git 9004f421527e335dadfbfbad44ed91f0083c3124

How reproducible:


Steps to Reproduce:
1. Create a swap partition into the hard disk with LVM
2. Boot the computer from the LiveCD
3. LiveCD init script detects and activates the swap partition
4. Start an installation
5. When partitioning choose "Remove Linux partitions on selected drives and
create default layout"
6. Click Next until the installation begins, then anaconda crashes

  
Actual results:

lvremove fails trying to remove the LV in use.

Expected results:

The swap should be deactivated.

Additional info:
Comment 1 Àlex Magaz Graça 2007-09-19 05:17:10 EDT
Created attachment 199371 [details]
anaconda crash dump
Comment 2 Chris Lumens 2007-09-19 09:51:48 EDT

*** This bug has been marked as a duplicate of 295601 ***

Note You need to log in before you can comment on or make changes to this bug.