Bug 296091 - Invisible Mouse Pointer in Fedora 8 Test 2
Invisible Mouse Pointer in Fedora 8 Test 2
Status: CLOSED DUPLICATE of bug 182517
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mouse (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-19 06:47 EDT by Kulbir Saini
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-22 08:25:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kulbir Saini 2007-09-19 06:47:07 EDT
Description of problem:When Fedora took me to X server through autologin in
Fedora 8 Test 2 KDE LiveCD, the mouse pointer just disappeared. It was visible
while Fedora was starting all the services. Well, I used to get the same
invisible mouse pointer in FC5, FC6 and F7 too. But after adding a line <Options
"HWCursor" "off"> in screen section in xorg.conf and on relogin everything used
to work fine. But in Live CD I tried adding the same line and it didn't work out.

One more thing, all the other effects work, like I can click object, mouse over
effect is working fine.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results: The mouse pointer in invisible in X server.

Expected results: The mouse pointer should be visible.


Additional info:
My machine details are 
Mobo - Gigabyte nVidia nForce 4 with nVidia GeForce 6100 onboard
Mouse - MicroSoft Optical USB mouse.
I think other details are not of any use to this bug.

I can't provide the X-log and all because on launching beryl everything crashed
and it thrown me the command line and there of I couldn't start the X. So, just
rebooting without copying the logs anywhere :(
Comment 1 Ville Skyttä 2007-11-21 12:29:53 EST
I see similar effects on F8, KDE, ASUS GeForce 6150 onboard video chip, xorg
"nv" driver.  No compiz/beryl, no rhgb, nothing special.

For me the cursor is almost always visible, but every now and then, it just
disappears; IIRC most often when logging out and back in, but sometimes also
after idling and coming back from monitor suspend state.  I haven't tried
touching the HWCursor setting nor actually tweaked xorg.conf at all.  Will try
that now.

The same box has never before F8 exhibited this behaviour, no such problems eg.
in F7.  Before F8 it has always had the proprietary NVIDIA display drivers
installed, now the regular xorg nv.
Comment 2 Matěj Cepl 2007-11-22 08:25:39 EST

*** This bug has been marked as a duplicate of 182517 ***

Note You need to log in before you can comment on or make changes to this bug.