Bug 29789 - xvideo is not working on voodoo3
xvideo is not working on voodoo3
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 34734 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-27 12:50 EST by jari.lietzen
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-05 13:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86 Log File from XFree86-4.0.3-5 (21.18 KB, text/plain)
2001-04-05 09:40 EDT, Scott Russell
no flags Details
XFree86 config file from XFree86-4.0.3-5 (1.78 KB, text/plain)
2001-04-05 09:41 EDT, Scott Russell
no flags Details
XFree86 log file for the non-working version (21.16 KB, text/plain)
2001-04-05 11:11 EDT, jari.lietzen
no flags Details
XFree86 log file for the working version (21.58 KB, text/plain)
2001-04-05 11:13 EDT, jari.lietzen
no flags Details
XF86config-4 for the working and non-working versions (2.36 KB, text/plain)
2001-04-05 11:14 EDT, jari.lietzen
no flags Details
Nils' XFree86.0.log (23.81 KB, text/plain)
2001-04-06 16:44 EDT, Nils Philippsen
no flags Details
Nils' XF86Config-4 (1.68 KB, text/plain)
2001-04-06 16:46 EDT, Nils Philippsen
no flags Details
Output of xvinfo (1.06 KB, text/plain)
2001-04-06 16:46 EDT, Nils Philippsen
no flags Details
Output of xine (523 bytes, text/plain)
2001-04-06 16:47 EDT, Nils Philippsen
no flags Details
strace of xine (27.24 KB, text/plain)
2001-04-06 16:48 EDT, Nils Philippsen
no flags Details
Interleaved output and strace of xine (27.31 KB, text/plain)
2001-04-06 16:50 EDT, Nils Philippsen
no flags Details

  None (edit)
Description jari.lietzen 2001-02-27 12:50:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.4.2 i686)




Reproducible: Always
Steps to Reproduce:
1. try to watch a mpeg-1 or mpeg-2 movie with xine or xmovie 
2. if the player is using xvideo for playback, the movie won't play and the
player exits
3.
	

Configuration:
3dfx Voodoo3 2000 PCI
RedHat 7.0 with XFree86-4.0.2 taken from Wolverine
2.4.2 kernel (SMP)


This is what xine tells:

This is xine - a mpeg 1, 2 player v0.3.7 - (c) 2000 by G. Bartsch.
testing for audio driver: oss <-(successfully initialized)
Using oss audio output driver.
 !! no port attributes defined
found yv12 format
video_out_xv: using Xvideo port 74 for hw scaling
        *** Settings: 
        *****************
Using X Window System video extension for video output.
set_image_format_xv(): width=720, height=405, ratio=3
scaled picture size : 720 x 405 (corr_factor: 0.999323)
shared memory error: Invalid argument
error when allocating image


And this is what xvinfo tells:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "3dfx Accelerated Video Engine"
    number of ports: 1
    port base: 74
    operations supported: PutImage 
    supported visuals:
      depth 16, visualID 0x23
      depth 16, visualID 0x24
      depth 16, visualID 0x25
      depth 16, visualID 0x26
      depth 16, visualID 0x27
      depth 16, visualID 0x28
      depth 16, visualID 0x29
      depth 16, visualID 0x2a
      depth 16, visualID 0x2b
      depth 16, visualID 0x2c
      depth 16, visualID 0x2d
      depth 16, visualID 0x2e
      depth 16, visualID 0x2f
      depth 16, visualID 0x30
      depth 16, visualID 0x31
      depth 16, visualID 0x32
    no port attributes defined
    maximum XvImage size: 1024 x 0
    Number of image formats: 2
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
Comment 1 Mike A. Harris 2001-02-27 17:06:50 EST
You've filed a bug report against XFree86-Servers-3.3.6, and have mentioned
4.0.2 in the text.  If this is a 4.0.2 problem, please change the component
to XFree86 proper.  If it is 3.3.6, please indicate so clearly below...

Also, please try to reproduce on a full install of Wolverine as I do not
have hardware to verify or test with.  There are new packages in Rawhide
which might help also.
Comment 2 jari.lietzen 2001-03-01 10:41:07 EST
I've changed the component to XFree86.  This is a 4.0.2 bug.

I tried the new packages from Rawhide, but the problem persists. Xine will play
movies if it's told to use X shared memory extension for playback.

Comment 3 Mike A. Harris 2001-03-15 07:32:38 EST
Try disabling DRI.  If that doesn't work, please include your X server logs
and config file via the file attach link below.
Comment 4 jari.lietzen 2001-04-01 06:46:03 EDT
I just installed XFree86-4.0.3 packages from rawhide, but the problem is still
there. I have also downloaded and compiled the DRI source from
http://dri.sourceforge.net/ I downloaded the source from their CVS about three
weeks ago. This version is working fine. I keep the different installations in
different directories, so the switching between them is easy.
Comment 5 Nils Philippsen 2001-04-02 10:35:25 EDT
Verified this at home, doesn't work with or without DRI. XF86Config and logs
will follow (when I'm at home).
Comment 6 Mike A. Harris 2001-04-05 03:09:04 EDT
Logs and config?  ;o)
Comment 7 Mike A. Harris 2001-04-05 03:13:27 EDT
*** Bug 34734 has been marked as a duplicate of this bug. ***
Comment 8 Scott Russell 2001-04-05 09:38:47 EDT
In doing some testing of 7.1 BETA it seems the same problem is present in the
current builds as of 04/05. Attached are my XFree86.log and XFree86-4 config files.
Comment 9 Scott Russell 2001-04-05 09:40:37 EDT
Created attachment 14725 [details]
XFree86 Log File from XFree86-4.0.3-5
Comment 10 Scott Russell 2001-04-05 09:41:38 EDT
Created attachment 14726 [details]
XFree86 config file from XFree86-4.0.3-5
Comment 11 jari.lietzen 2001-04-05 11:11:47 EDT
Created attachment 14731 [details]
XFree86 log file for the non-working version
Comment 12 jari.lietzen 2001-04-05 11:13:16 EDT
Created attachment 14732 [details]
XFree86 log file for the working version
Comment 13 jari.lietzen 2001-04-05 11:14:40 EDT
Created attachment 14733 [details]
XF86config-4 for the working and non-working versions
Comment 14 Nils Philippsen 2001-04-06 16:41:47 EDT
Ok, finally attaching some logs (hope it doesn't fail again):

- X server (just the not working case)
- XF86Config-4
- xvinfo
- xine
- strace of xine
- interleaved xine + strace of xine
Comment 15 Nils Philippsen 2001-04-06 16:44:09 EDT
Created attachment 14823 [details]
Nils' XFree86.0.log
Comment 16 Nils Philippsen 2001-04-06 16:46:02 EDT
Created attachment 14824 [details]
Nils' XF86Config-4
Comment 17 Nils Philippsen 2001-04-06 16:46:58 EDT
Created attachment 14825 [details]
Output of xvinfo
Comment 18 Nils Philippsen 2001-04-06 16:47:55 EDT
Created attachment 14826 [details]
Output of xine
Comment 19 Nils Philippsen 2001-04-06 16:48:46 EDT
Created attachment 14827 [details]
strace of xine
Comment 20 Nils Philippsen 2001-04-06 16:50:49 EDT
Created attachment 14828 [details]
Interleaved output and strace of xine
Comment 21 Nils Philippsen 2001-04-06 16:54:38 EDT
What's notable is that xvinfo reports a maximum XvImage size of 1024x0 pixels,
can't possibly work, can it? Mine is XFree86-4.0.3-5 as well.
Comment 22 Mike A. Harris 2001-05-10 21:35:53 EDT
I have asked upstream about this problem and am awaiting a response from
the XFree86 and DRI development groups.
Comment 23 Yue Shi Lai 2001-05-17 14:26:38 EDT
The problem seems not to affect the current DRI Development Builds (at
dri.sourceforge.net). XVideo works fine for my Voodoo 3 2000 AGP and AVILib also
uses hardware acceleration. But their X server (development 4.0.0, as I can
remember) is not very stable, I would not recommend to use it. I think that the
DRI group should know the reason why XVideo is not working in the 4.0.3 server
(may be the XVideo tree for 3Dfx has not been merged to the current XFree86
4.0.3 release).
Comment 24 NILMONI DEB 2001-07-05 13:12:54 EDT
This problem has been resolved in X4.1.0, as confirmed by bugfix #621 in 
http://www.xfree86.org/cvs/changes_4_1.html .

I had the same problem with X4.0.3 but with X4.1.0 I am getting great acceleration.
Now my xvinfo looks like:

X-Video Extension version 2.2
screen #0
  Adaptor #0: "3dfx Video Overlay"
    number of ports: 1
    port base: 46
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x23
      depth 24, visualID 0x24
      depth 24, visualID 0x25
      depth 24, visualID 0x26
    number of attributes: 2
      "XV_COLORKEY" (range 0 to 16777215)
              client settable attribute
              client gettable attribute (current value is 30)
      "XV_FILTER_QUALITY" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
Comment 25 Mike A. Harris 2001-08-08 09:07:14 EDT
Confirmed fixed in 4.1.0-0.9.11 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.