Bug 298071 - Segmentation fault running eclipse -application org.eclipse.ant.core.antRunner
Segmentation fault running eclipse -application org.eclipse.ant.core.antRunner
Status: CLOSED DUPLICATE of bug 350291
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
ppc64 Linux
medium Severity low
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 09:09 EDT by Robert Marcano
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 07:00:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Marcano 2007-09-20 09:09:05 EDT
Description of problem:
When building eclipse-subclipse

Version-Release number of selected component (if applicable):
Rawhide

How reproducible:
always happens building eclipse-subclipse Fedora package

Steps to Reproduce:
1. Checkout eclipse-subclipse from CVS
2. run make srpm on devel branch
3. rebuild the RPM
  
Actual results:
/var/tmp/rpm-tmp.48384: line 57:   654 Segmentation fault      eclipse
-application org.eclipse.ant.core.antRunner -Duser.home=$homedir -Dtype=feature
-Did=org.tigris.subversion.subclipse -DsourceDirectory=$(pwd)
-DbaseLocation=$SDK
-Dbuilder=/usr/share/eclipse/plugins/org.eclipse.pde.build/templates/package-build
-f /usr/share/eclipse/plugins/org.eclipse.pde.build/scripts/build.xml

Expected results:
Build the RPM without problems like on F-7 and FC-6

Additional info:

http://koji.fedoraproject.org/koji/getfile?taskID=167365&name=build.log
Comment 1 Andrew Overholt 2007-09-20 10:25:09 EDT
I don't have a ppc64 box on which to test this :(.
Comment 2 Robert Marcano 2007-10-19 09:24:56 EDT
I disabled ppc64 build, but still the upgrade path will be broken for previous
fedora users on ppc64, just requested help on the devel list looking for someone
with a ppc64
Comment 3 Andrew Overholt 2007-10-22 15:06:22 EDT
So this is really a gcj on ppc64 but, right?  Should we ask Andrew Haley to take
a look at it?
Comment 4 Andrew Haley 2007-10-23 05:27:29 EDT
This is probably the kernel bug here

http://gcc.gnu.org/ml/gcc/2007-10/msg00197.html

Waiting a kernel update.
Comment 5 Andrew Haley 2007-10-25 07:00:36 EDT

*** This bug has been marked as a duplicate of 350291 ***

Note You need to log in before you can comment on or make changes to this bug.