Bug 350291 - Unwinding stack on PPC 64 corrupts CR
Unwinding stack on PPC 64 corrupts CR
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
low Severity high
: ---
: ---
Assigned To: David Howells
Fedora Extras Quality Assurance
:
: 298071 (view as bug list)
Depends On:
Blocks: 335861 420551
  Show dependency treegraph
 
Reported: 2007-10-24 07:30 EDT by Andrew Haley
Modified: 2007-12-11 16:10 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.23.1-42.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 19:43:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the kernel (1.03 KB, patch)
2007-10-25 11:11 EDT, David Howells
no flags Details | Diff

  None (edit)
Description Andrew Haley 2007-10-24 07:30:03 EDT
During gcc testing we discovered a bug in the kernel unwinder data which causes
the CR register to be corrupted when throwing an exception through the vDSO.

There is a patch applied upstream.

http://gcc.gnu.org/ml/gcc/2007-10/msg00197.html

There is a test case at http://gcc.gnu.org/ml/gcc/2007-10/msg00184.html

This bug is preventing some packages from ebing built.
Comment 2 Andrew Haley 2007-10-25 07:00:37 EDT
*** Bug 298071 has been marked as a duplicate of this bug. ***
Comment 3 David Howells 2007-10-25 10:08:11 EDT
This patch looks reasonable to me.
Comment 4 David Howells 2007-10-25 11:11:24 EDT
Created attachment 237451 [details]
Patch to fix the kernel
Comment 5 Chuck Ebbert 2007-10-25 14:26:09 EDT
Fedora 8 blocker??
Comment 6 Robert Marcano 2007-10-25 14:48:52 EDT
It is for me, I can not rebuild eclipse-subclipse por ppc64 users, leaving a
broken upgrade path for them, see Bug #298071
Comment 7 Chuck Ebbert 2007-10-25 16:52:49 EDT
Okay, in Fedora 8 kernel CVS.
Comment 9 Chuck Ebbert 2007-11-06 19:43:37 EST
Fix is in Fedora 8 release.
Comment 10 David Woodhouse 2007-11-13 21:34:07 EST
Fixed for FC6 in kernel-2.6.22.12-70.fc6

Note You need to log in before you can comment on or make changes to this bug.