Bug 298271 - yum, package manager, does not open
Summary: yum, package manager, does not open
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 7
Hardware: ia64
OS: Linux
low
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-20 15:17 UTC by hazem
Modified: 2014-01-21 22:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-31 14:54:23 UTC
Type: ---


Attachments (Terms of Use)
debugging information (2.79 KB, text/plain)
2007-09-20 15:17 UTC, hazem
no flags Details

Description hazem 2007-09-20 15:17:56 UTC
After i have updated my fedora 7 system using the software updater by selecting
all available updates, and after restarting computer, the package manager could
not be open, and yum has failed and a message box has appeared giving some
debugging information and asked me to send a bug report contains a message which
is in the attached file.

after i have logged out and login as root, package manager has worked properly,
then i have logged in as a normal user, and also i found that the package
manager is working !!!

thank you very much for your effort

Comment 1 hazem 2007-09-20 15:17:56 UTC
Created attachment 200831 [details]
debugging information

Comment 2 Jeremy Katz 2007-09-20 15:47:32 UTC
If you run 'yum clean all' as root and then try again, does it work?

Comment 3 hazem 2007-09-24 22:26:00 UTC
(In reply to comment #2)
> If you run 'yum clean all' as root and then try again, does it work?

it is too slow, the package manager window or the update manager takes long time
to start and some times does not start at all (nothing happens after clicking to
start the package manager) even after using the clean command you told me about.

but this was not the situation days ago, the system was working very well, this
problem happened after choosing to update all packages using the update manager.

thank you very much.

Comment 4 hazem 2007-09-24 22:31:23 UTC
(In reply to comment #2)
> If you run 'yum clean all' as root and then try again, does it work?

i have tried to run the package manager again, it went away for looooong time
then the a dialog box appeared telling the following message


Component: pirut
Summary: TB11af5ff9 grabber.py:1219:_do_grab:OSError: [Errno 2] No such file or
directory: '//var/cache/yum/fedora/primary.sqlite.bz2'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 441, in <module>
    main()
  File "/usr/sbin/pirut", line 434, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 61, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 124, in __init__
    self.reset()
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 223, in reset
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 521, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 151, in populate
    db_fn = repo.retrieveMD(mydbtype)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 839, in retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 607, in _getFile
    http_headers=headers,
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 411, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.5/site-packages/urlgrabber/mirror.py", line 397, in
_mirror_try
    return func_ref( *(fullurl,), **kwargs )
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 927, in
urlgrab
    return self._retry(opts, retryfunc, url, filename)
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 845, in _retry
    r = apply(func, (opts,) + args, {})
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 915, in
retryfunc
    fo._do_grab()
  File "/usr/lib/python2.5/site-packages/urlgrabber/grabber.py", line 1219, in
_do_grab
    os.utime(self.filename, (modified_stamp, modified_stamp))
OSError: [Errno 2] No such file or directory:
'//var/cache/yum/fedora/primary.sqlite.bz2'

Local variables in innermost frame:
self: <urlgrabber.grabber.URLGrabberFileObject instance at 0x1039248>
amount: None
modified_stamp: 1183492954.0
new_fo: <closed file '//var/cache/yum/fedora/primary.sqlite.bz2', mode 'wb' at
0x102d3f0>
bs: 8192
modified_tuple: (2007, 7, 3, 20, 2, 34, 0, 1, 0, 0)
ValueError: unpack non-sequence
block: 
size: 4955910


Comment 5 Seth Vidal 2007-12-07 03:10:48 UTC
Did this problem every change or go away for you? I don't think we can recreate
it here but I want to make sure it's not a transient network error.

Thanks


Comment 6 Jeremy Katz 2007-12-31 14:54:23 UTC
Closing due to inactivity.  Please reopen or file a new bug if you have further
information to add to this bug report


Note You need to log in before you can comment on or make changes to this bug.