Bug 298481 - nspluginwrapper makes the browser crash
nspluginwrapper makes the browser crash
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 290901 298501 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-20 12:15 EDT by Julian Sikorski
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-09-20 12:15:40 EDT
Description of problem:
When flash plugin is used through wrapper, the browser crashes. Using the flash
plugin natively works fine.

Version-Release number of selected component (if applicable):
firefox-2.0.0.5-1.fc7.x86_64
nspluginwrapper-0.9.91.5-1.fc8.i386
nspluginwrapper-0.9.91.5-1.fc8.x86_64
flash-plugin-9.0.60.184-release.i386

How reproducible:
always

Steps to Reproduce:
1. Install the above software
2. Set up the flash plugin to be wrapped 
3. Go to http://web.playmobile.pl/pl/play-abonament/index.html
  
Actual results:
browser crashes

Expected results:
no crash

Additional info:
Flash plugin is the latest beta from adobe labs. I set up the plugin wrapper with:
/usr/lib64/nspluginwrapper/npconfig -i /usr/lib/mozilla/plugins/libflashplayer.so
Comment 1 Bill Nottingham 2007-09-20 15:18:48 EDT
*** Bug 298501 has been marked as a duplicate of this bug. ***
Comment 2 Julian Sikorski 2007-09-20 15:28:07 EDT
Oh. Sorry for the dupe. I was having some problems with bugzilla.
Comment 3 Martin Stransky 2007-09-21 02:39:54 EDT
you're right, it crashes for me, too.
Comment 4 Martin Stransky 2007-09-21 06:10:37 EDT
Anyway, you should install your plugins by "mozila-plugin-config" utility... but
it doesn't matter for this bug.
Comment 5 Julian Sikorski 2007-09-21 06:20:38 EDT
I know, but mozilla-plugin-config installs them into
%{_libdir}/mozilla/plugins-wrapped, which requires rawhide firefox, and I run
Fedora 7 here.
Comment 6 Martin Stransky 2007-10-04 10:24:23 EDT
Can you please check this package? 
It's w/o the plugin restart support and it doesn't crash for me.

http://people.redhat.com/stransky/mozilla/nspluginwrapper-0.9.91.5-4.test.fc8.src.rpm
Comment 7 Martin Stransky 2007-10-04 11:00:49 EDT
F7 binary packages are available at http://people.redhat.com/stransky/mozilla/
Comment 8 Julian Sikorski 2007-10-04 11:30:20 EDT
it's better now - no crash indeed. The newer flash itself crashes, though, but
this report should go elsewhere. Thanks for fixing that.
Comment 9 Martin Stransky 2007-10-04 11:37:57 EDT
Unfortunately it's not fixed :( I just removed one important feature :(
Comment 10 Martin Stransky 2007-10-04 11:38:35 EDT
*** Bug 290901 has been marked as a duplicate of this bug. ***
Comment 11 Martin Stransky 2007-10-09 11:16:26 EDT
Should be fixed in nspluginwrapper-0.9.91.5-5.fc8.

Note You need to log in before you can comment on or make changes to this bug.