Bug 298861 - CCS fix: magmamsg doesn't work if route is incorrect
Summary: CCS fix: magmamsg doesn't work if route is incorrect
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: ccs   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
: 354351 (view as bug list)
Depends On: 298831
Blocks: 362631
TreeView+ depends on / blocked
 
Reported: 2007-09-20 18:41 UTC by Lon Hohberger
Modified: 2009-04-16 20:34 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-1036
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 21:56:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ccs patch (1.29 KB, text/x-patch)
2007-09-20 18:41 UTC, Lon Hohberger
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:1036 normal SHIPPED_LIVE ccs bug fix update 2007-11-29 14:49:08 UTC

Description Lon Hohberger 2007-09-20 18:41:25 UTC
+++ This bug was initially created as a clone of Bug #298831 +++

Description of problem:

If multiple IP addresses are bound to the same interface on the same subnet as
the primary cluster communications path, an incorrect routing configuration will
cause magmamsg (and therefore, other applications like rgmanager and ccsd) to
not function correctly.

For example:

   eth0   192.168.78.1
   eth0:1 192.168.78.10

If the cluster's hostname resolves to 192.168.78.1 - but the kernel routes
packets via the 192.168.78.0/24 subnet out via .10, the other members of the
cluster will deny the connection because .10 is does not match a cluster
member's IP address.

There are two solutions: DNS aliasing and this fix, which requires minor changes
to applications which use magmamsg.

Version-Release number of selected component (if applicable): 1.0.7-1
How reproducible: 100%
Steps to Reproduce:  As described

-- Additional comment from lhh@redhat.com on 2007-09-20 14:38 EST --
Created an attachment (id=201151)
Magma patch - applications should call msg_set_nodeid() prior to msg_open if
they use 'members_only' when doing msg_accept

Comment 1 Lon Hohberger 2007-09-20 18:41:26 UTC
Created attachment 201161 [details]
Ccs patch

Comment 2 Lon Hohberger 2007-10-26 16:25:16 UTC
*** Bug 354351 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2007-11-21 21:56:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1036.html



Note You need to log in before you can comment on or make changes to this bug.