Bug 354351 - CCS fix: magmamsg doesn't work if route is incorrect
CCS fix: magmamsg doesn't work if route is incorrect
Status: CLOSED DUPLICATE of bug 298861
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: ccs (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-26 11:58 EDT by Lon Hohberger
Modified: 2009-07-22 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 12:25:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small patch to make ccs work with prerouting patch for magma (1.29 KB, patch)
2007-10-26 11:58 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Lon Hohberger 2007-10-26 11:58:18 EDT
+++ This bug was initially created as a clone of Bug #298831 +++

Description of problem:

If multiple IP addresses are bound to the same interface on the same subnet as
the primary cluster communications path, an incorrect routing configuration will
cause magmamsg (and therefore, other applications like rgmanager and ccsd) to
not function correctly.

For example:

   eth0   192.168.78.1
   eth0:1 192.168.78.10

If the cluster's hostname resolves to 192.168.78.1 - but the kernel routes
packets via the 192.168.78.0/24 subnet out via .10, the other members of the
cluster will deny the connection because .10 is does not match a cluster
member's IP address.
Comment 1 Lon Hohberger 2007-10-26 11:58:18 EDT
Created attachment 239261 [details]
Small patch to make ccs work with prerouting patch for magma
Comment 2 Lon Hohberger 2007-10-26 12:25:15 EDT

*** This bug has been marked as a duplicate of 298861 ***
Comment 3 Lon Hohberger 2007-10-26 12:26:17 EDT
Removing dependency.  Closed+Duplicate bugs depend on and block nothing

Note You need to log in before you can comment on or make changes to this bug.