This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 29989 - Problems with .i386.rpm of KDE 2.1 for RedHat 7.0
Problems with .i386.rpm of KDE 2.1 for RedHat 7.0
Status: CLOSED DUPLICATE of bug 29987
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-28 04:33 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-28 04:33:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-28 04:33:07 EST
Hello!

I have downloaded the i386 rpms of KDE 2.1 from KDE and I have troubles
with them. I had installed KDE 2.1 beta 2 without problems but now when
I try to update the packages with rpm -Fvh * I got the following answer:

[root@lorient i386]# rpm -Fvh *
error: failed dependencies:
        libsensors.so.1 is needed by kdebase-2.1-0.70.3
        libkdefakes.so.0 is needed by kdebindings-2.1-0.beta2
        libkdefakes.so.0 is needed by kdbg-1.2.0-2
        libkdefakes.so.0 is needed by kdestudio-2.0.0-1pp
        libkdefakes.so.0 is needed by cervisia-1.0beta3-1
[root@lorient i386]#

The packages being:


htdig-3.2.0-0.b2.2.i386.rpm              kdepim-2.1-0.70.3.i386.rpm
htdig-web-3.2.0-0.b2.2.i386.rpm          kdesdk-2.1-0.70.2.i386.rpm
kdeadmin-2.1-0.70.3.i386.rpm            
kdesdk-devel-2.1-0.70.2.i386.rpm
kdebase-2.1-0.70.3.i386.rpm              kdesupport-2.1-0.70.2.i386.rpm
kdegames-2.1-0.70.3.i386.rpm            
kdesupport-devel-2.1-0.70.2.i386.rpm
kdegraphics-2.1-0.70.2.i386.rpm          kdetoys-2.1-0.70.2.i386.rpm
kdelibs-2.1-0.70.2.i386.rpm              kdeutils-2.1-0.70.2.i386.rpm
kdelibs-devel-2.1-0.70.2.i386.rpm        kdevelop-1.4-0.70.5.i386.rpm
kdelibs-sound-2.1-0.70.2.i386.rpm        qt-2.2.4-0.70.4.i386.rpm
kdelibs-sound-devel-2.1-0.70.2.i386.rpm  qt-Xt-2.2.4-0.70.4.i386.rpm
kdemultimedia-2.1-0.70.2.i386.rpm       
qt-designer-2.2.4-0.70.4.i386.rpm
kdenetwork-2.1-0.70.2.i386.rpm           qt-devel-2.2.4-0.70.4.i386.rpm
kdenetwork-ppp-2.1-0.70.2.i386.rpm       qt-static-2.2.4-0.70.4.i386.rpm
 

I have also noticed that compared to beta2, arts-2.1 and the 3
kdebinding-2.1 rpms are missings. Could you please tell me how to fix
the problem and where I could find the missing packages.

Thanks in advance


                        Daniel
Comment 1 Bernhard Rosenkraenzer 2001-02-28 04:54:47 EST

*** This bug has been marked as a duplicate of 29987 ***
Comment 2 Need Real Name 2001-02-28 06:48:30 EST
I check bugs 29987 and it is slightly different than mine. I have a beta2
version of arts-2.1 installed. This does not prevent the KDE 2.1 rpms for not
installing.
Comment 3 Need Real Name 2001-03-01 04:49:10 EST
Hi!

I picked up the package of arts-2.1 on the kde.org ftp server and I still have
the problems mentionned in this bug, that is to say :

 [root@lorient i386]# rpm -Fvh *
 error: failed dependencies:
         libsensors.so.1 is needed by kdebase-2.1-0.70.3
         libkdefakes.so.0 is needed by kdebindings-2.1-0.beta2
         libkdefakes.so.0 is needed by kdbg-1.2.0-2
         libkdefakes.so.0 is needed by kdestudio-2.0.0-1pp
         libkdefakes.so.0 is needed by cervisia-1.0beta3-1
 [root@lorient i386]#


Daniel
Comment 4 Bernhard Rosenkraenzer 2001-03-01 04:55:39 EST
libsensors is in the lm_sensors package.
The dependencies on libkdefakes.so.0 are problems with 3rd party applications 
you've installed. You need to recompile kdebindings, kdbg, kdestudio and 
cervisia. libkdefakes.so.0 was never part of an official KDE release.

Alternatively,
ln -sf /usr/lib/libkdefakes.so.3 /usr/lib/libkdefakes.so.0
and use rpm --nodeps, there are no ABI changes in libkdefakes that I'm aware 
of.
Comment 5 Need Real Name 2001-03-01 05:22:09 EST
Ok, I think I understood. Just two questions: where does the lm_sensors package
come from and where can I find the keybinding package? It was a part of kde2.1
beta 2 but is not in kde 2.1 anymore.

Daniel
Comment 6 Need Real Name 2001-03-01 07:12:28 EST
Hi!

I found lm_sensors and I read that it is not for 2.2 kernels. What am I supposed
to do then?

Name        : lm_sensors                   Relocations: (not relocateable)
Version     : 2.5.5                             Vendor: Red Hat, Inc.
Release     : 2                             Build Date: Tue 06 Feb 2001 05:06:47
AM CET
Install date: (not installed)               Build Host: porkchop.redhat.com
Group       : Applications/System           Source RPM: (none)
Size        : 366696                           License: GPL
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.netroedge.com/~lm78/
Summary     : Hardware monitoring tools.
Description :
The lm_sensors package includes a collection of modules for general SMBus
access and hardware monitoring.  NOTE: this requires special support which
is not in standard 2.2-vintage kernels.
lm_sensors-2.5.2-redhat.patch
lm_sensors-2.5.5-glibc22.patch
lm_sensors-2.5.5-ic2_block.patch
lm_sensors-2.5.5.tar.gz
lm_sensors.spec
Comment 7 Bernhard Rosenkraenzer 2001-03-01 07:19:47 EST
Simply rpm -i --nodeps it, lm_sensors is used by a kcontrol status display

only, and not strictly needed.
Comment 8 Need Real Name 2001-03-01 07:33:04 EST
OK, but what about kdebinding? Where do I find it?

Daniel
Comment 9 Need Real Name 2001-03-01 08:39:54 EST
BTW, there is no .src.rpm of arts-2.1 given for redhat 7.0. The binary is there
but not the source.

Daniel

Note You need to log in before you can comment on or make changes to this bug.