Bug 301051 - thunderbird quits unexpectedly (X Window System error, BadRequest)
thunderbird quits unexpectedly (X Window System error, BadRequest)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
6
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-21 14:59 EDT by Michael V. Antosha
Modified: 2008-01-15 09:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 09:39:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from gdb, thunderbird crashing, BadRequest (37.62 KB, text/plain)
2007-09-21 14:59 EDT, Michael V. Antosha
no flags Details
backtrace at gdk_x_error() (98.46 KB, text/plain)
2007-10-08 06:25 EDT, Michael V. Antosha
no flags Details

  None (edit)
Description Michael V. Antosha 2007-09-21 14:59:45 EDT
Description of problem:

For the history of my problem, please, refer to Bug 277941 (libwnck) and Bug
282691 (xchat).
I have similar problems with firefox, as well, but I haven't caught the proof
for that yet.

Well... I discovered the "-g" option of thunderbird today. I tried to make use
of it to catch some information for opening this bug report. Now I have the
initial information.

I'll attach the output from gdb, with some additional information.
You can see there that I run thunderbird as "mivael-thunderbird" executable.
I'll explain why. I'm a "keyboard guy", the one who doesn't like mouse clicking.
That's why I frequently use such form of running thunderbird as "thunderbird
-compose" (from the "Run Application" Alt+F2 dialog window) for composing new
mail messages... That usually happens so much times per day that I do it
automatically, without noticing it. I was not sure, if it's right to use
"thunderbird -compose" when debugging my thunderbird with "-g" option... That's
why I renamed (temporarily) "/usr/bin/thunderbird" to
"/usr/bin/mivael-thunderbird", to prevent accidental use of "thunderbird
-compose" form of running...
I computed (the same attachment) SHA-1 digest on "mivael-thunderbird" for you to
be sure the script was not changed comparing to the original "/usr/bin/thunderbird".

As you can see from the attachment, gdb showed me this error message when my
thunderbird disappeared:
===
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 8389622 error_code 1 request_code 0 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Program exited with code 01.
(gdb)
===

I'm not sure how to run thunderbird with the "--sync" option.
Should I just use something like the following?

   thunderbird -g --sync

("mivael-thunderbird -g --sync" in my case)


Version-Release number of selected component (if applicable):

   thunderbird-1.5.0.10-1.fc6.src.rpm


How reproducible:

I just run "thunderbird -g", and use it during the day, not closing it, even
when I don't need it...
Sooner or later it crashes. Can't predict the moment of crashing. It seems some
actions (mouse/keyboard events) results in sudden crash. It's certainly not the
same event every tim
e, but different situations after some key press or mouse click/move.


Actual results:

Process dies, thunderbird windows disappear.
Comment 1 Michael V. Antosha 2007-09-21 14:59:45 EDT
Created attachment 202701 [details]
output from gdb, thunderbird crashing, BadRequest
Comment 2 Michael V. Antosha 2007-10-08 06:25:02 EDT
Created attachment 219571 [details]
backtrace at gdk_x_error()

Another crash.
More meaningfull backtrace here.
Comment 3 Christopher Aillon 2007-10-09 12:03:17 EDT
Can you install thunderbird-debuginfo and get another gdb backtrace?
Comment 4 Michael V. Antosha 2007-10-10 03:20:59 EDT
That's somewhat problematic, because of relatively big (61 MiB) download size
for that (I have certain limitations). But I'll try to do it as soon as I find
it possible.
Comment 5 Matěj Cepl 2007-12-10 04:22:09 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 6 Matěj Cepl 2008-01-15 09:39:06 EST
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

{This is mass-closing of all obsolete bugs; if this bug was in your opinion
closed by mistake, please, reopen it with additional information; thanks a lot
and I am sorry for bothering you in such case.}

Note You need to log in before you can comment on or make changes to this bug.