Bug 282691 - xchat quits unexpectedly with transparent background (X Window System error, BadRequest BadDrawable)
xchat quits unexpectedly with transparent background (X Window System error, ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 438296 446339 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-07 12:35 EDT by Michael V. Antosha
Modified: 2008-05-30 22:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.8.4-16.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 22:13:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gdb: xchat received an X Window System error: BadRequest (5.25 KB, text/plain)
2007-09-07 12:35 EDT, Michael V. Antosha
no flags Details
xchat --sync crashed (12.55 KB, text/plain)
2007-09-24 11:31 EDT, Michael V. Antosha
no flags Details
starting to debug with debuginfo -- the breakpoint resolved (4.34 KB, text/plain)
2007-09-25 10:56 EDT, Michael V. Antosha
no flags Details
backtrace caught at gdk_x_error() (16.47 KB, text/plain)
2007-10-08 06:12 EDT, Michael V. Antosha
no flags Details

  None (edit)
Description Michael V. Antosha 2007-09-07 12:35:18 EDT
Description of problem:

For the history of the problem, please, refer to "Bugzilla Bug 277941":

   https://bugzilla.redhat.com/show_bug.cgi?id=277941

I'm having similar problems not only with xchat, but anyway I had to start from
somewhere.
Well... last two or three days I've been using my xchat from under gdb, hoping
to catch some proof about existing of my problems  :)

Today it's happened.
I'm attaching the output from gdb.
And I'm ready to continue doing something in order to find what causes my
problems... (I'll be away for about a week, although. But later I'll be
available for continuing.)

I included in the attachment all I thought might be significant, but please
don't make fun of me: I know almost nothing about gdb for now :)

It seems, the most significant part of the attachment is this:
===
The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 8430999 error_code 1 request_code 0 minor_code 0)
[...]
Program exited with code 01.
No registers.
(gdb)
===

Two words about how my xchat crashed...
I was dragging the scrollbar of xchat window up and down, up and down, up and
down...    :)
In the middle of such move the xchat window suddenly disappeared -- that's all.
I got (in gdb terminal window) that messages about "X Window System error".


Version-Release number of selected component (if applicable):

   xchat-2.6.6-4.fc6.src.rpm


How reproducible:

As you can see from timestamps (in the attachment), it's somewhat hard to
reproduce. Unpredictable, it seems.
  
Actual results:

Process dies, window disappears.
Comment 1 Michael V. Antosha 2007-09-07 12:35:18 EDT
Created attachment 190141 [details]
gdb: xchat received an X Window System error: BadRequest
Comment 2 Kevin Kofler 2007-09-10 15:02:30 EDT
Can you please try running:
gdb --args xchat --sync
so we get a real backtrace?
Comment 3 Michael V. Antosha 2007-09-18 07:22:52 EDT
Okay, I'll try.

I think we'll get the backtrace in a day or so...
Comment 4 Michael V. Antosha 2007-09-21 15:02:41 EDT
xchat still works without crashing (with --sync option)... I'm still waiting...

By the way, thunderbird shows similar error when it crashes (Bug 301051).
Comment 5 Michael V. Antosha 2007-09-24 11:31:00 EDT
Created attachment 204261 [details]
xchat --sync crashed

My xchat crashed today. Now with "--sync" option. gdb output is in the
attachment.
But I don't see any significant difference between this gdb output and the
previous one.

I guess I had to use gdb break points mechanism to get the stack trace?

Well... now I'm debugging my xchat again, with the break point arranged. I hope
it'll work and we'll have the stack trace. What I'm doing now is this:

$ gdb --args xchat --sync
[...]
(gdb) set height 0
(gdb) break gdk_x_error
Function "gdk_x_error" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y
Breakpoint 1 (gdk_x_error) pending.
(gdb) run
Starting program: /usr/bin/xchat --sync
[...]
Comment 6 Kevin Kofler 2007-09-24 11:37:30 EDT
Is the pending breakpoint ever getting resolved? (That should happen shortly 
after the "Starting program" line.) If it is, it should work, if it's not, then 
it won't.
Comment 7 Kevin Kofler 2007-09-24 11:39:16 EDT
Moreover, installing some -debuginfo packages (before you start gdb) should 
result in a more useful backtrace, I guess at least gtk2-debuginfo and 
xchat-debuginfo would be useful.
Comment 8 Michael V. Antosha 2007-09-25 03:19:18 EDT
(In reply to comment #6)
>
> Is the pending breakpoint ever getting resolved?

It seems it is not. These are examples of all kinds of messages, that follows
the "starting program" one:

   (no debugging symbols found)
   [Thread debugging using libthread_db enabled]
   [New Thread -1208805696 (LWP 9365)]

Those are all kinds for now.

> If it is, it should work, if it's not, then it won't.

Do I have the pending breakpoint resolved if I will install gtk2-debuginfo and
xchat-debuginfo packages?

If not then what I have to do to make gdb resolve that breakpoint?
Comment 9 Kevin Kofler 2007-09-25 09:35:58 EDT
> Do I have the pending breakpoint resolved if I will install gtk2-debuginfo
> and xchat-debuginfo packages?

Maybe. Please try it.
Comment 10 Michael V. Antosha 2007-09-25 10:56:55 EDT
Created attachment 205571 [details]
starting to debug with debuginfo -- the breakpoint resolved

Okay, I'm trying now.
I've updated the gtk2 package and installed -debuginfo packages for xchat and
gtk2.
That helped in resolving the breakpoint.

Now I'm waiting for the moment when the breakpoint triggers.
Comment 11 Michael V. Antosha 2007-10-08 06:12:25 EDT
Created attachment 219521 [details]
backtrace caught at gdk_x_error()

It's happened. Here is the backtrace at gdk_x_error(), just before xchat exits
with "BadRequest" error message.

Meanwhile, I recently created a new bug, with libX11 as a component:

   Bug 318561

I'm not sure libX11 is the source of my problems, but it might be.
Comment 12 Jeroen van Meeuwen 2007-12-28 15:09:19 EST
This happens again in rawhide (xchat-2.8.4-9.fc9):

[jmeeuwen@elwood ~]$ xchat
The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadPixmap (invalid Pixmap parameter)'.
  (Details: serial 22185 error_code 4 request_code 54 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Comment 13 Dave Russell 2008-03-19 10:34:37 EDT
It's also present in F8, I haven't seen this behavior in F7.

$ xchat

Gdk-ERROR **: The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2046495 error_code 9 request_code 146 minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...

(process:5221): Gdk-ERROR (recursed) **: The program 'xchat' received an X
Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2046496 error_code 9 request_code 14 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Aborted

I'm maybe seeing it crash once a day on average, maybe a bit longer.
Comment 14 Kevin Kofler 2008-03-19 20:00:04 EDT
I think this isn't a bug in XChat itself, but in one of the libraries. The 
backtrace shows calls from XChat to GTK to GDK to Pango to Cairo to X11 and 
only there it crashes, and the only XChat code involved in the backtrace is the 
one starting the main event loop.
Comment 15 Kevin Kofler 2008-04-28 13:28:22 EDT
*** Bug 438296 has been marked as a duplicate of this bug. ***
Comment 16 Kevin Fenzi 2008-04-28 13:32:38 EDT
I am seeing this here every time. ;( 

Let me know what debugging info would be helpfull for you and I would be happy
to gather it. 
Comment 17 Kevin Fenzi 2008-05-06 11:30:55 EDT
Would gdb or strace output from me help any here?

xchat crashes after launching everytime here. 
intel video, fully updated rawhide/proto-f9. 

The program 'xchat' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadPixmap (invalid Pixmap parameter)'.
  (Details: serial 987 error_code 4 request_code 54 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

xchat-2.8.4-15.fc9.x86_64
xorg-x11-drv-i810-2.2.1-24.fc9.x86_64
xorg-x11-server-common-1.4.99.901-28.20080415.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-28.20080415.fc9.x86_64

Happy to provide info... this is a pretty anoying bug. 
Comment 18 Kevin Fenzi 2008-05-06 11:56:22 EDT
Here's the stack trace from here: 

Starting program: /usr/bin/xchat --sync
[Thread debugging using libthread_db enabled]
[New Thread 0x2ba7537acaa0 (LWP 19796)]
[Switching to Thread 0x2ba7537acaa0 (LWP 19796)]

Breakpoint 1, gdk_x_error (display=0xfab1c0, error=0x7fff589a8b10) at
gdkmain-x11.c:614
614	  if (error->error_code)
(gdb) where
#0  gdk_x_error (display=0xfab1c0, error=0x7fff589a8b10) at gdkmain-x11.c:614
#1  0x00000031a5c45524 in _XError (dpy=<value optimized out>, rep=<value
optimized out>)
    at XlibInt.c:2905
#2  0x00000031a5c4cf5f in process_responses (dpy=<value optimized out>, 
    wait_for_first_event=<value optimized out>, current_error=<value optimized
out>, 
    current_request=<value optimized out>) at xcb_io.c:138
#3  0x00000031a5c4d30a in _XReply (dpy=<value optimized out>, rep=<value
optimized out>, 
    extra=<value optimized out>, discard=<value optimized out>) at xcb_io.c:370
#4  0x00000031a5c40db3 in XSync (dpy=<value optimized out>, 
    discard=<value optimized out>) at Sync.c:48
#5  0x00000031a5c40f6b in _XSyncFunction (dpy=<value optimized out>) at Synchro.c:37
#6  0x00000031a5c26ef4 in XFreePixmap (dpy=<value optimized out>, 
    pixmap=<value optimized out>) at FreePix.c:43
#7  0x00000031af064eaa in gdk_pixmap_impl_x11_dispose (object=Could not find the
frame base for "gdk_pixmap_impl_x11_dispose".
) at gdkpixmap-x11.c:103
#8  0x00000031a8c0d632 in IA__g_object_unref (_object=<value optimized out>)
    at gobject.c:1765
#9  0x00000031af02b294 in gdk_pixmap_finalize (object=Could not find the frame
base for "gdk_pixmap_finalize".
) at gdkpixmap.c:226
#10 0x00000031a8c0d6a8 in IA__g_object_unref (_object=<value optimized out>)
    at gobject.c:1793
#11 0x00000031af022512 in IA__gdk_gc_set_values (gc=Could not find the frame
base for "IA__gdk_gc_set_values".
) at gdkgc.c:306
#12 0x00000031af022a18 in IA__gdk_gc_set_tile (gc=Could not find the frame base
for "IA__gdk_gc_set_tile".
) at gdkgc.c:447
#13 0x000000000043904b in gtk_xtext_load_trans (xtext=0x1045b50) at xtext.c:3850
#14 0x000000000043c6b0 in gtk_xtext_size_allocate (widget=0x1045b50, 
    allocation=<value optimized out>) at xtext.c:1111
#15 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#16 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#17 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#18 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#19 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#20 0x00000031afd32ee2 in gtk_frame_size_allocate (widget=Could not find the
frame base for "gtk_frame_size_allocate".
) at gtkframe.c:660
#21 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#22 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#23 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
---Type <return> to continue, or q <return> to quit---
    var_args=<value optimized out>) at gsignal.c:2199
#24 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#25 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#26 0x00000031afd38110 in gtk_hbox_size_allocate (widget=Could not find the
frame base for "gtk_hbox_size_allocate".
) at gtkhbox.c:243
#27 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#28 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#29 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#30 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#31 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#32 0x00000031afee90f8 in gtk_vbox_size_allocate (widget=Could not find the
frame base for "gtk_vbox_size_allocate".
) at gtkvbox.c:234
#33 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#34 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#35 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#36 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#37 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#38 0x00000031afee90f8 in gtk_vbox_size_allocate (widget=Could not find the
frame base for "gtk_vbox_size_allocate".
) at gtkvbox.c:234
#39 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#40 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#41 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#42 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#43 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
---Type <return> to continue, or q <return> to quit---
#44 0x00000031afda7c88 in gtk_notebook_size_allocate (widget=Could not find the
frame base for "gtk_notebook_size_allocate".
) at gtknotebook.c:2123
#45 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#46 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#47 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#48 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#49 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#50 0x00000031afd38a85 in gtk_hpaned_size_allocate (widget=Could not find the
frame base for "gtk_hpaned_size_allocate".
) at gtkhpaned.c:215
#51 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#52 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#53 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#54 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#55 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#56 0x00000031afd38ab9 in gtk_hpaned_size_allocate (widget=Could not find the
frame base for "gtk_hpaned_size_allocate".
) at gtkhpaned.c:217
#57 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#58 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#59 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#60 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#61 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#62 0x00000031afee90f8 in gtk_vbox_size_allocate (widget=Could not find the
frame base for "gtk_vbox_size_allocate".
) at gtkvbox.c:234
#63 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
---Type <return> to continue, or q <return> to quit---
    at gclosure.c:490
#64 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#65 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#66 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#67 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#68 0x00000031afe2e678 in gtk_table_size_allocate_pass2 (table=Could not find
the frame base for "gtk_table_size_allocate_pass2".
) at gtktable.c:1634
#69 0x00000031afe2c488 in gtk_table_size_allocate (widget=Could not find the
frame base for "gtk_table_size_allocate".
) at gtktable.c:862
#70 0x00000031a8c0b62f in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#71 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#72 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#73 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#74 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#75 0x00000031aff06646 in gtk_window_size_allocate (widget=Could not find the
frame base for "gtk_window_size_allocate".
) at gtkwindow.c:4733
#76 0x00000031a8c0b6dd in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#77 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#78 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#79 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#80 0x00000031afef3497 in IA__gtk_widget_size_allocate (widget=Could not find
the frame base for "IA__gtk_widget_size_allocate".
) at gtkwidget.c:3818
#81 0x00000031aff0575b in gtk_window_show (widget=Could not find the frame base
for "gtk_window_show".
) at gtkwindow.c:4275
#82 0x00000031a8c0b6dd in IA__g_closure_invoke (closure=<value optimized out>, 
    return_value=<value optimized out>, n_param_values=<value optimized out>, 
    param_values=<value optimized out>, invocation_hint=<value optimized out>)
    at gclosure.c:490
#83 0x00000031a8c1efd6 in signal_emit_unlocked_R (node=<value optimized out>, 
    detail=<value optimized out>, instance=<value optimized out>, 
---Type <return> to continue, or q <return> to quit---
    emission_return=<value optimized out>, instance_and_params=<value optimized
out>)
    at gsignal.c:2370
#84 0x00000031a8c20b9c in IA__g_signal_emit_valist (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>, 
    var_args=<value optimized out>) at gsignal.c:2199
#85 0x00000031a8c210e3 in IA__g_signal_emit (instance=<value optimized out>, 
    signal_id=<value optimized out>, detail=<value optimized out>) at gsignal.c:2243
#86 0x00000031afef1cd0 in IA__gtk_widget_show (widget=Could not find the frame
base for "IA__gtk_widget_show".
) at gtkwidget.c:2943
#87 0x000000000042ab3e in mg_changui_new (sess=0xff2590, res=0xff2d60, 
    tab=<value optimized out>, focus=1) at maingui.c:3119
#88 0x000000000041b6a2 in fe_new_window (sess=0xfab1c0, focus=0) at fe-gtk.c:380
#89 0x0000000000460af4 in session_new (serv=0xff1890, from=0x0, type=2, focus=1)
    at xchat.c:346
#90 0x0000000000460d3c in new_ircwindow (serv=0xff1890, name=0x0, 
    type=<value optimized out>, focus=1) at xchat.c:363
#91 0x000000000045a5d3 in servlist_connect (sess=0x0, net=0xff0c00, join=1)
    at servlist.c:504
#92 0x000000000045a73f in servlist_auto_connect (sess=0x0) at servlist.c:627
#93 0x000000000046056b in xchat_auto_connect (userdata=<value optimized out>)
    at xchat.c:681
#94 0x00000031a7c3749b in IA__g_main_context_dispatch (context=<value optimized
out>)
    at gmain.c:2009
#95 0x00000031a7c3ac7d in g_main_context_iterate (context=<value optimized out>, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2642
#96 0x00000031a7c3b1ad in IA__g_main_loop_run (loop=<value optimized out>)
    at gmain.c:2850
#97 0x00000031afd84888 in IA__gtk_main () at gtkmain.c:1163
#98 0x000000000041b789 in fe_main () at fe-gtk.c:291
#99 0x000000000046151d in main (argc=2, argv=0x7fff589ae498) at xchat.c:1065
Comment 19 Kevin Fenzi 2008-05-06 12:02:34 EDT
Sorry for not attaching that stack trace. ;( 
It was larger than I thought and I just cut and pasted it without thinking. ;( 
Comment 20 Kevin Kofler 2008-05-06 12:04:14 EDT
This looks a lot like a GTK+ bug, reassigning to gtk2.
Comment 21 Bug Zapper 2008-05-13 23:12:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 22 Kevin Kofler 2008-05-15 06:17:38 EDT
Is this caused by transparent background being enabled (see bug 446339)?
Comment 23 Kevin Fenzi 2008-05-15 11:01:43 EDT
It seems to be. 

I set: 

text_transparent = 0

in my ~/.xchat2/xchat.conf file and tried starting it. 
Comes up fine with that setting. ;( 
Comment 24 Kevin Kofler 2008-05-15 11:21:22 EDT
*** Bug 446339 has been marked as a duplicate of this bug. ***
Comment 25 Kevin Kofler 2008-05-22 17:25:20 EDT
This is caused by SHM pixmap support: SHM pixmaps are not always available in 
F9 (IIRC, EXA doesn't support them), and Ajax's patch to disable them at 
runtime when they're not available looks very much incomplete to me.

I'll try fixing the patch, and if that doesn't help, I'll try a build with SHM 
pixmap support disabled entirely.
Comment 26 Kevin Kofler 2008-05-22 20:06:03 EDT
Should be fixed in xchat-2.8.4-16.fc9:
http://koji.fedoraproject.org/koji/taskinfo?taskID=625434
Please try it.
Comment 27 Eric Mertens 2008-05-22 21:14:25 EDT
That (2.8.4-16.fc9) fixed my crash, thank you
Comment 28 Fedora Update System 2008-05-22 21:25:26 EDT
xchat-2.8.4-16.fc9 has been submitted as an update for Fedora 9
Comment 29 Kevin Fenzi 2008-05-22 22:12:46 EDT
Yep. Fixes it here too... thanks for the great work!
Comment 30 Fedora Update System 2008-05-28 22:42:59 EDT
xchat-2.8.4-16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xchat'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-4511
Comment 31 Fedora Update System 2008-05-30 22:13:04 EDT
xchat-2.8.4-16.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.