Bug 30194 - problem with backspace key in vim
problem with backspace key in vim
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-01 14:03 EST by kris
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 14:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kris 2001-03-01 14:03:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i586)


This bug is similar to the one reported in Bug#10389 with fewer components
required to induce the error.  I do not have Screen installed, yet from
both the Konsole and xterm terminal emulators, in a Vim session, pressing
the backspace key presents a literal "^?" to the screen.  This does not
occur
when using the kvt emulator or using a terminal outside of X, and unlike
bug 10389 where this occurred for only an su to root, it occurs for all
users.

Reproducible: Always
Steps to Reproduce:
1.run vim from Konsole or Xterm
2.press backspace key (the character '^?' is output to the file)
3.does not occur in kvt or non-X terminal, does occur for every system user

	

Actual Results:  ^?
Comment 1 kris 2001-03-01 14:34:32 EST
This was actually due to a default setting in these emulators setting the
backspace to key to issue a delete "^?" sequence...not a bug.

Note You need to log in before you can comment on or make changes to this bug.