This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 302141 - Move /usr/share/fonts/ from fontconfig to filesystem
Move /usr/share/fonts/ from fontconfig to filesystem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
: Reopened
: 302421 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-09-23 07:05 EDT by Nicolas Mailhot
Modified: 2015-03-04 20:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 11:30:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2007-09-23 07:05:58 EDT
Since font packages can drop files in /usr/share/fonts/ without depending on
fontconfig, ownership of /usr/share/fonts/ should be moved from fontconfig to
filesystem

Since the change is trivial and is needed by many packages -> blocker
Comment 1 Jens Petersen 2007-09-24 00:15:51 EDT
*** Bug 302421 has been marked as a duplicate of this bug. ***
Comment 2 Matthias Clasen 2007-10-03 12:17:37 EDT
Hardly a blocker issue
Comment 3 Behdad Esfahbod 2007-10-25 21:03:03 EDT
My bad.  filesystem still doesn't own /usr/share/fonts.

Also, filesystem creates /etc/fonts/conf.d, but doesn't own it in %files.  Is
that intentional?  If not, probably other entries are missing too.

Please reassign back to fontconfig after resolving.
Comment 4 Phil Knirsch 2008-03-27 11:30:25 EDT
/etc/fonts/conf.d is already covered by the /etc line in %files.

I've just added /usr/share/fonts to the list and building a new version today in
rawhide.

Thanks,

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.