Bug 30236 - first login and sawfish workspace config
Summary: first login and sawfish workspace config
Status: CLOSED DUPLICATE of bug 17674
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawfish   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 00:07 UTC by Nicholas J Kreucher
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 01:25:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicholas J Kreucher 2001-03-02 00:07:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9smp i686)


upon the first initial login for a user, going to sawfish config, then
workspaces
then changing the number ot workspaces to one and making the rows=1 and 
cols=4 (or any number) then clicking OK makes the deskguide show still 4
workspaces
with 4 cols in them each (lots of desktops!). logging out and then logging
back in fixes the problem and deskguide_applet shows the correct number of
workspaces, cols an rows.

note that killing deskguide applet and then starting it back up does not
fix the problem, and that makes me think it's a sawfish problem.

Reproducible: Always
Steps to Reproduce:
1. login to newly created account on fresh install
2. change sawfish workspaces=1, rows=1, cols=4
3. click OK
	

Actual Results:  deskguide applet still shows 4 workspaces and then 4 cols
of desktops in each (too many!)

Expected Results:  1 workspace with 4 desktops side by side (4 cols)

this has been happening ever since redhat 7 and also in helix-code/ximian
gnome

Comment 1 Havoc Pennington 2001-03-02 01:46:28 UTC
John may know this one already

Comment 2 Need Real Name 2001-03-20 01:25:34 UTC
This is due to the `preserve empty workspaces in pager' option being set. It
does seem like a misfeature though

Comment 3 Havoc Pennington 2001-07-12 18:59:36 UTC
Dup of 17674, upstream as http://bugzilla.eazel.com/show_bug.cgi?id=8409

*** This bug has been marked as a duplicate of 17674 ***


Note You need to log in before you can comment on or make changes to this bug.