Bug 30326 - dlopen dlsym dlclose
Summary: dlopen dlsym dlclose
Status: CLOSED DUPLICATE of bug 24080
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man-pages   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 16:36 UTC by Need Real Name
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 16:36:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-02 16:36:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


the dlopen(3) page, as well as dlsym(3) and dlclose(3) and associated
dynamic library loading pages are gone from the man-pages RPM, and indeed
from the entire distribution.

Reproducible: Always
Steps to Reproduce:
1.  mount each Redhat 7.0 distro CD.
2.  run " rpm -qlp /mnt/cdrom/Redhat/RPMS/* | grep 'dlopen' "
	

Actual Results:  This command only yields results for man-pages-pl and
man-pages-ja

Expected Results:  There should have been a dlopen.3.gz file somewhere in
english.

The CHANGELOG for Tue May 30 2000 says that they were removed because they
are in other packages; however, running " rpm -qlp /mnt/cdrom/Redhat/RPMS/*
| grep 'dlopen' " for each distribution CD only yields results for the
man-pages-pl and man-pages-ja packages.  What other package includes these
man pages?

Comment 1 Trond Eivind Glomsrxd 2001-03-02 16:41:08 UTC
It was part of the ld.so package, which was dropped shrotly after (it's only
necesarry for libc5).

The man pages have since returned.

*** This bug has been marked as a duplicate of 24080 ***


Note You need to log in before you can comment on or make changes to this bug.