Bug 30367 - xferlog/syslog records with timestamps in UTC instead of local timezone
Summary: xferlog/syslog records with timestamps in UTC instead of local timezone
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anonftp   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 33573 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-02 20:10 UTC by Andrei Ivanov
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 09:25:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrei Ivanov 2001-03-02 20:10:36 UTC
All transfers logged to /var/log/xferlog or syslog are UTC timestamped
(instead of local timezone). This is because in chroot'ed environment
there is no information about timezone in use.

Workaround: put copy of the /etc/localtime zoneinfo file into /home/ftp/etc
directory (may be accomplished by postinstall script in RPM package?)

Comment 1 Bernhard Rosenkraenzer 2001-08-22 12:11:14 UTC
*** Bug 33573 has been marked as a duplicate of this bug. ***

Comment 2 Matt Selsky 2002-02-07 05:36:07 UTC
The same problem occurs with ls output in rh7.2 (wu-ftpd-2.6.1-20).  I was able
to workaround this by copying /etc/localtime into the chroot()'ed environment.

Comment 3 Thomas Woerner 2004-08-13 09:25:04 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.