Bug 304231 - No fonts found - missing Requires
No fonts found - missing Requires
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Radek Vokal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-24 19:07 EDT by Charles R. Anderson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 523129 (view as bug list)
Environment:
Last Closed: 2007-10-18 04:17:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles R. Anderson 2007-09-24 19:07:00 EDT
Description of problem:

Running wireshark on a minimal system results in this error message:

No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual

Version-Release number of selected component (if applicable):
0.99.6-1.fc6

How reproducible:
always

Steps to Reproduce:
1. install minimal system without X
2. yum install xauth wireshark-gnome
3. ssh -X remotehost and run "wireshark"
  
Actual results:

# wireshark
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual

# yum install xorg-x11-fonts-Type1
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xorg-x11-fonts-Type1 to pack into transaction set.
xorg-x11-fonts-Type1-7.1- 100% |=========================|  14 kB    00:00     
---> Package xorg-x11-fonts-Type1.noarch 0:7.1-2 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 xorg-x11-fonts-Type1    noarch     7.1-2            core              1.5 M

Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 1.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): xorg-x11-fonts-Typ 100% |=========================| 1.5 MB    00:00     
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: xorg-x11-fonts-Type1         ######################### [1/1] 

Installed: xorg-x11-fonts-Type1.noarch 0:7.1-2
Complete!
# wireshark

... runs correctly ...

Expected results:
wireshark-gnome should have proper Requires: for whatever fonts it needs to run,
so they get pulled in automatically with "yum install wireshark-gnome".

Additional info:

I'm not sure of the exact Requires here, I ran the following commands in this
order until wireshark started working:

yum install wireshark-gnome
yum install xauth
yum install xorg-x11-font-utils
yum install xorg-x11-fonts-misc
yum install xorg-x11-fonts-base
yum install xorg-x11-fonts-truetype
yum install xorg-x11-fonts-Type1

lsof shows the running wireshark-gnome has these font files open:

wireshark  8492      root  mem       REG      253,0    77488   24249271
/usr/share/X11/fonts/Type1/l047013t.pfa
wireshark  8492      root  mem       REG      253,0    70121   24249279
/usr/share/X11/fonts/Type1/l048013t.pfa
wireshark  8492      root  mem       REG      253,0    72496   24249281
/usr/share/X11/fonts/Type1/l048016t.pfa
Comment 1 Bill Nottingham 2007-10-03 12:54:01 EDT
The problem is twofold:

1) apps that use fontconfig almost certainly need some sort of fonts

2) you can't really have requires to do this correctly, as any font that an app
requests will go through both the system font aliasing, and *any user's own font
configuration*. So there's no way to synthesize 100% correct requires back to a
package or file name.

Note You need to log in before you can comment on or make changes to this bug.