Bug 523129 - no fonts found
Summary: no fonts found
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-services
Version: 5.3
Hardware: i386
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Nils Philippsen
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 08:29 UTC by michelemase
Modified: 2009-09-14 15:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 304231
Environment:
Last Closed: 2009-09-14 15:17:55 UTC


Attachments (Terms of Use)

Description michelemase 2009-09-14 08:29:43 UTC
Description of problem:

Running system-config-network on a minimal system results in this error message:
to be ignored start
libglade-WARNING **: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory
to be ignored end
error:
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual

Version-Release number of selected component (if applicable):
0.9.4 1-el5

How reproducible:
always if xorg-x11-fonts-Type1 is missing

Steps to Reproduce:

1. install minimal system without X
2. yum install xauth system-config-network
3. ssh -X remotehost and run "system-config-network"
  
Actual results:
system-config-services 

(system-config-services:7347): libglade-WARNING **: Could not load support for `gnome': libgnome.so: cannot open shared object file: No such file or directory
No fonts found; this probably means that the fontconfig
library is not correctly configured. You may need to
edit the fonts.conf configuration file. More information
about fontconfig can be found in the fontconfig(3) manual

yum -y install -q xorg-x11-fonts-Type1
This system is not registered with RHN.
RHN support will be disabled.
system-config-services

... runs correctly ...

Expected results:

system-config-network should have proper Requires: for whatever fonts it needs to run, so they get pulled in automatically with "yum install system-config-network".

Additional info:

lsof shows the running system-config-network has these font files open:

system-co  7898      root  mem       REG      253,4    72496      36609 /usr/share/X11/fonts/Type1/l048016t.pfa
system-co  7898      root  mem       REG      253,4    70121      36607 /usr/share/X11/fonts/Type1/l048013t.pfa

This bug should be a clone of  Bug 304231 -  No fonts found - missing Requires

Since a lot of GUI packages complains about missing fonts reporting the general error "No fonts found bla bla bla ...", and you can fix it simply by installing the xauth and xorg-x11-fonts-Type1 package, a possible solution could be "adding xorg-x11-fonts-Type1 as a dipendence of the xauth package"

Comment 1 Phil Knirsch 2009-09-14 15:17:55 UTC
Closing with the same argument as bug #304231.

Thanks & regards, Phil


Note You need to log in before you can comment on or make changes to this bug.