Bug 304851 - Please use opengl-games-utils DRI checking wrapper
Please use opengl-games-utils DRI checking wrapper
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 08:01 EDT by Hans de Goede
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-26 11:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-09-25 08:01:12 EDT
In preperation for the Games Live DVD, I've created a small bash script which
resides in opengl-games-utils, which is meant to be used as a wrapper around
OpenGL games. If DRI is available this wrapper does nothing, if it isn't it will
show an error dialog, explaining about Free Software and 3D drivers and then exit.

The idea here is that an error dialog is better then trying to click the quit
menu option while the mouse is jumping from the right edge of the screen to the
left edge (mouse navigation is anything but easy at 3 fps).

This is esp. important for the Games Live DVD, as there people will not have
those other <beep> drivers available.

Adding the wrapper is _really_ easy:

1) Add: "Requires: opengl-games-utils"
2) Add to %install:
"ln -s opengl-game-wrapper.sh $RPM_BUILD_ROOT%{_bindir}/%{name}-wrapper"
3) Add "%{_bindir}/%{name}-wrapper" to %files
4) Change the .desktop file Exec entry from "%{name}" to "%{name}-wrapper"

This all assumes your main binary name == %{name}, otherwise adapt as necessary.

If you already have a wrapper script for one reason or the other, you can
incorperate the checkDriOk function directly into your wrapper, no need todo a
wrapper wrapper, see vegastrike's vegastrike-wrapper.sh CVS file as example.
Comment 1 Jochen Schmitt 2007-09-25 10:42:39 EDT
I have try out your suggestion.

Unfortunately, I will get an error message even I have running the nvidia driver
from rpms.linva.org.

For this reason, I will discard you request of using your opengl-games-utils
package.
Comment 2 Nicolas Chauvet (kwizart) 2007-09-25 11:20:48 EDT
Indeed! nVidia closed driver do not use dri at all!
Comment 3 Jochen Schmitt 2007-09-25 11:29:56 EDT
Yes, but stellarium is running fine with the nvidia driver, so there is no
reason to prohibits this. That may be a drawback for the users of this application. 
Comment 4 Hans de Goede 2007-09-25 13:21:22 EDT
Ugh, I agree this is bad, but not using the wrapper is not the solution, the
wrapper should be fixed. I naively assumed that the nvidea and fglrx drivers
where both using dri as well (I'm pretty sure the fglrx driver is, but I'll give
it a try).

Can you please attach the output of glxinfo for an nvidea card, then I'll try to
come up with a fixed version of the script.

Luckily I put the script in a seperate rpm and did not copy and paste it to a
gazillion game packages, cases like this being exactly the reason to have the
script in one central place.
Comment 5 Jochen Schmitt 2007-09-26 10:47:00 EDT
I have take effort to examinate the reported issue. I have find out, that the
permissions of the device files was set improperly. So I have open BZ #1653 on
rpm.livna.org
Comment 6 Jochen Schmitt 2007-09-26 11:44:50 EDT
I have built stellarium-0.90-5 for development and still poking the nvidia
maintainer on livna to fix the reporting bug.

Note You need to log in before you can comment on or make changes to this bug.