Bug 30507 - anaconda signal 11 during FTP install of rc2
anaconda signal 11 during FTP install of rc2
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-03 19:35 EST by Brent Nordquist
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-13 21:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-03-03 19:35:53 EST
Installing Florence rc2 on beta hardware #46, as an FTP install
(bootnet.img floppy) from ftp.beta.redhat.com -- text mode portions worked
fine and it loaded the ramdisks, but when starting anaconda I immediately
got "install exited abnormally -- received signal 11".  There was no
opportunity presented to capture to floppy disk.  128MB of RAM in this

The last lines on VT3:
	going to insmod ext3.o (path is NULL)
	looking for USB mouse...
The last lines on VT4:
	<4> raid5: using function: p5_mmx (1050.00 MB/sec)
	<6> raid5 personality registered as nr 4
VT2 was showing a shell prompt (#) but I couldn't type any commands.
Comment 1 Matt Wilson 2001-03-03 21:07:46 EST
what is beta hardware #46?
Comment 2 Matt Wilson 2001-03-03 21:09:26 EST
oh, sorry - found it.
Comment 3 Michael Fulbright 2001-03-05 12:50:59 EST
Did RC1 work with this hw configuration?
Comment 4 Brent Nordquist 2001-03-05 13:20:07 EST
Unfortunately I didn't get around to trying RC1 on this particular box.  I can
certainly try RC1 tonight if it would help; let me know.

But what would the answer (RC1 sig11's or doesn't) tell you?  It seems to me
that (1) nothing should cause anaconda to signal 11, should it?  To me that
suggests that parameters aren't being checked, null pointers being used, etc. 
You should at least get an error message.  And (2) if it does crash, shouldn't
it always give the opportunity for a traceback, so that Red Hat would have
something concrete to examine?
Comment 5 Glen Foster 2001-03-05 15:45:10 EST
This defect considered a show-stopper (MUST-FIX) for Florence GOLD release
Comment 6 Brent Nordquist 2001-03-07 21:33:35 EST
OK, got some time to try RC1 on this hardware, and it fails too, in the same
way.  Furthermore, specifying "nofb", "lowres", and "text" doesn't change it...
signal 11 upon starting anaconda, every time.  This machine worked fine during
RH7 testing, and it's stable with RH7 in daily use.
Comment 7 Matt Wilson 2001-03-08 12:43:02 EST
how much ram?
Comment 8 Brent Nordquist 2001-03-08 14:38:34 EST
128MB, as stated above in the initial problem report.  :-)
Comment 9 Matt Wilson 2001-03-08 14:47:43 EST
blah.  this is all pretty standard hardware - I have no idea why it may be
Comment 10 Brent Nordquist 2001-03-08 15:00:11 EST
Agreed.  Well, at one point in the past, your QA lab set up a machine similar to
mine, to test and reproduce a problem with disk druid partition creation.  I'm
sure you have all these pieces; as you say, it's all pretty common.

About the only thing I haven't provided is my disks:  I have three ultra/wide
Quantum drives (sda=4.5G, sdb=4.5G, sdc=9G), and then a narrow Plextor CD.  (The
only IDE is a CD burner and a ZIP drive (ATAPI).)  I'm installing 7.1 on parts
of sdb and sdc.

I'm happy to do whatever I can to help... run a custom kernel and/or initrd with
debug code, that sort of thing.
Comment 11 Matt Wilson 2001-03-08 15:04:30 EST
are the the 3 lines above "install exited abnormally"?
Comment 12 Brent Nordquist 2001-03-08 15:44:18 EST
There is nothing above the "abnormally" line.  The sequence of events:  the TUI
windows ask for language, keyboard, etc; "loading aic78xx" or something like
that appears (loading the SCSI driver); "starting anaconda" or something like
that appears very briefly; the screen clears to complete blue, and then "install
exited abnormally" appears as the top line of VT1; literally it's in position
(1,1) in the upper-left-hand corner.  There are a few other messages that appear
after that, stair-stepped down the page (like \r without \n is happening).

You can see the VT2, VT3, VT4 lines above.
Comment 13 Matt Wilson 2001-03-08 16:41:37 EST
please place the files at http://people.redhat.com/msw/debug on an ext2
formatted floppy disk and boot with "linux updates"
Comment 14 Brent Nordquist 2001-03-09 08:20:56 EST
OK, I did that.  Unfortunately, here's what I got:

Running anaconda - please wait...
  File "/tmp/updates/anaconda.real", line 515
    print "done.
SyntaxError: invalid token
install exited abnormally
sending termination signals... done

Looking at it now, clearly I should have just added a double-quote and tried
again... but I was very tired and wasn't thinking straight.  Sorry about that,
I'll try again tonight and let you know; tell me if there are other fixes beyond
that one line that I need.
Comment 15 Matt Wilson 2001-03-09 10:15:49 EST
yea - I can't get much further without this run.  Sorry about the typo...
Comment 16 Brent Nordquist 2001-03-10 13:05:55 EST
OK, well, the output I got:

hello, world
import installinterface
make todo
install exited abnormally [etc.]

I added a few more print statements:  Just before method is instantiated, the
string value is "ftp://ftp.nordist.net/7.1/rc2/i386" and it gets into the
"ftp:// or http://" case to instantiate method.  Then, just before the "make
todo" line, I think rootPath is "/mnt/sysimage" (I didn't write that one down...
sorry, but I do know it's defined, and is "/mnt" something).

At that point, I can't continue tracing, because I don't have the source for the
ToDo stuff.  I'm happy to trace down further in if you'll tell me how to do

Here is the input I give to the installer between boot and anaconda running, in
case the values matter (these are the actual values I'm using), although
anaconda crashes with ftp.beta.redhat.com (non-anonymous) too:

    Choose a Language
    Keyboard Type
    Installation Method
    Configure TCP/IP
        [ ] Use dynamic ...
        IP address:
        Default gateway (IP):
        Primary nameserver:
    FTP Setup
        FTP site name: ftp.nordist.net
        Red Hat directory: 7.1/rc2/i386
        [ ] Use non-anonymous ftp

At that point, ramdisks are loaded, and the AIC 7xxx driver, and then anaconda
Comment 17 Matt Wilson 2001-03-10 13:11:13 EST
I'm going to bet that it is in the kudzu code.  I've added a todo.py file to
Comment 18 Brent Nordquist 2001-03-10 13:29:48 EST
This time we didn't even get to hello, world:

Running anaconda - please wait...
error 2 reading header: cpio: Bad magic
cpio failed on (null): (internal)
install exited abnormally -- received signal 7

I just dropped todo.py next to anaconda and anaconda.real on the ext2 floppy --
root:root 755 for all three.
Comment 19 Matt Wilson 2001-03-10 18:50:45 EST
it ran out of space expanding stage 2.  Try putting only todo.py on the updates
Comment 20 Brent Nordquist 2001-03-10 21:36:47 EST
Well, you sure nailed it:

instanciate mouse object
install exited abnormally

FWIW, I have a Microsoft Intellimouse PS/2 (one of the optical ones) in this
Comment 21 Matt Wilson 2001-03-11 03:18:55 EST
PS/2 or USB?
Comment 22 Brent Nordquist 2001-03-11 18:04:22 EST
This one can do either... I have it connected to the PS/2 port with the
USB-to-PS/2 short adapter cable thingie that came with it.
Comment 23 Matt Wilson 2001-03-11 19:32:20 EST
Can you try running the install without the mouse attached or with it attached
to usb?
Comment 24 Brent Nordquist 2001-03-12 07:34:36 EST
With the mouse completely disconnected (and after a hard reset), the same thing
happens (signal 11 after "instanciate mouse").  I don't have any USB on this
box, and don't really want to set all that up unless it's the only way for your
troubleshooting to continue.
Comment 25 Brent Nordquist 2001-03-12 14:38:41 EST
[Testing bugzilla bug 31493 by adding comments to a beta-only bug.]
Comment 26 Matt Wilson 2001-03-12 14:46:41 EST
try booting with "linux nousb" at the boot: prompt.  If this doesn't work I'll
need to work on getting a boot disk for you with debugging output in the mouse
probe routines (written in C, this takes some time.)
Comment 27 Brent Nordquist 2001-03-12 18:42:59 EST
Sadly, no, it does the same thing with "linux nousb".
Comment 28 Matt Wilson 2001-03-12 19:34:34 EST
I have a bootnet.img at http://people.redhat.com/msw/debug/bootnet-test.img that
will print debugging output as it probes each bus.  This should let me narrow it
down to a probe function.
Comment 29 Brent Nordquist 2001-03-12 20:08:00 EST
Well, we've changed the thing being studied, and now it doesn't crash.  (At
least, not in the same way.)  Here's what I get:

Probing OTHER bus
Probing PCI bus
Probing SBUS bus
Probing USB bus
Probing SERIAL bus (3-5 second pause at this point)
Probing PSAUX bus

then the "Welcome" dialog pops up.  Several more things are behind it on the
screen (including PARALLEL, SCSI, IDE, KEYBOARD, ISAPNP) but not all can be
read.  After the second dialog box, I get:

No Drives Found (requester)
An error has occurred - no valid devices were found on which to create new
filesystems. [...]

then it stops and reboots.
Comment 30 Brent Nordquist 2001-03-12 20:30:03 EST
# cat /proc/partitions
major   minor   #blocks   name   [...]

# lsmod
Module:   #pages:   Used by:
3c59x   22784   1
keybdev   1968   0   (unused)
hid   11072   0   (unused)
input   3232   0   [keybdev hid]
usb-uhci   21360   0   (unused)
usbcore   47408   1   [hid usb-uhci]

Now, if I boot "linux nousb" the only line that shows up under "lsmod" is 3c59x;
otherwise, all is the same ("No Drives Found").
Comment 31 Brent Nordquist 2001-03-12 20:31:06 EST
Again, no IDE in this machine -- all partitions are SCSI.
Comment 32 Matt Wilson 2001-03-12 22:04:43 EST
oh, sorry - I prepared a wolverine based boot disk.  That's why the scsi modules
didn't load

It looks like the mouse probe crash has been fixed.  Do you want a rc2 based
boot disk so you can finish a ftp install on this box?
Comment 33 Matt Wilson 2001-03-12 22:12:11 EST
or better yet, try the qa tree posted today.
Comment 34 Brent Nordquist 2001-03-12 23:57:00 EST
Unfortunately qa0309 crashes the same way as the original rc2 does (signal 11). 
So are we back to bus probing (debug) with the Florence RC2 code base?
Comment 35 Matt Wilson 2001-03-13 00:04:18 EST
*grumble grumble*.  I'll have a new boot disk soon, with the code from the
qa0309 tree.
Comment 37 Michael Fulbright 2001-03-13 12:18:15 EST
Waiting on feedback based on new bootimage.
Comment 38 Matt Wilson 2001-03-13 12:23:24 EST
(he can only do testing at night... we'll see if we can't get some good amount
of testing done tonight)
Comment 39 Brent Nordquist 2001-03-13 19:45:02 EST
With bootnet-test2.img (no arguments to LILO) I get:

Running anaconda - please wait...
error 2 reading header: cpio: Bad magic
cpio failed on (null): (internal)
install exited abnormally -- recieved signal 7

Now, that's loading the rc2 initrd's over FTP... I'm in the process of pulling
the qa0309 initrd's which are probably a better match (and perhaps required with
bootnet-test2.img?) but I wanted to get you the early feedback.  I'll let you
know how the qa0309 initrd's fare.
Comment 40 Brent Nordquist 2001-03-13 20:39:47 EST
Same results with the qa0309 initrd's (which I'll begin using from here out
unless you ask for something different).
Comment 42 Brent Nordquist 2001-03-13 21:39:31 EST
See my 2001-03-12 20:08 post; we're past the crash point, and I now have 
partitions.  Do you want the /proc/partitions and lsmod data this time (there's 
lots of it and I'd have to transcribe it).
Comment 43 Matt Wilson 2001-03-13 21:47:40 EST
that's quite odd.  If you could, please continue on with the install and I'd
like to try some debugging inside the installed system.
Comment 44 Brent Nordquist 2001-03-13 21:58:20 EST
The hitch is, I don't have the full qa0309 here; I brought a ZIP of the tree 
from disc1 home, leaving out the RPMS and docs directories, just so we could 
test the early part.  I only have modem Internet access from home.  :-(

It did get all the way through to the point where it would begin loading RPMs.  
I can do an overnight install of qa0309 from ftp.beta.redhat.com; if I do 
minimal install it will probably finish by tomorrow morning.
Comment 45 Matt Wilson 2001-03-14 10:44:37 EST
well, the fact that you've gotten past this point with my updated boot disk
means that it seems this crash is fixed in the new kudzu.

Note You need to log in before you can comment on or make changes to this bug.