Bug 305221 - broken optflags by default
broken optflags by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: 315551 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 10:50 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 07:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
-mtune, not --mtune (824 bytes, patch)
2007-09-25 10:50 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2007-09-25 10:50:43 EDT
Description of problem:

If you don't have redhat-rpm-config installed, the compiler is rather broken, as
RPM is passing it bogus options.

Version-Release number of selected component (if applicable):

rpm-4.4.2.2-0.5.rc2

Patch attached

Additional info:

The error message produced by gcc is:

cc1: error: unrecognized command line option "-fmtune=generic".

Apparently it's commenting on my radio.
Comment 1 Bill Nottingham 2007-09-25 10:50:43 EDT
Created attachment 205551 [details]
-mtune, not --mtune
Comment 2 Panu Matilainen 2007-09-25 14:57:17 EDT
Doh :) Thanks for spotting, fixed upstream now and will be fixed in 4.4.2.2
final due out real soon now.
Comment 3 Panu Matilainen 2007-10-03 01:28:19 EDT
*** Bug 315551 has been marked as a duplicate of this bug. ***
Comment 4 Panu Matilainen 2007-10-03 07:18:34 EDT
In rawhide now, but only available in builders ATM due to the F8-test3 freeze.

Note You need to log in before you can comment on or make changes to this bug.