Bug 315551 - RPM_OPT_FLAGS is wrong on x86_64
RPM_OPT_FLAGS is wrong on x86_64
Status: CLOSED DUPLICATE of bug 305221
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
8
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 12:04 EDT by Andrew Haley
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 01:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Haley 2007-10-02 12:04:08 EDT
Description of problem:

When building an RPM, I get

aph jc1: error: unrecognized command line option "-fmtune=generic"

And this is because rpmrc copntains the illegal gcc option --mtune=generic.

It should be  -mtune=generic (one dash)

/usr/lib/rpm/ia32e-linux/macros:11:%optflags            -O2 -g -m64 --mtune=generic
/usr/lib/rpm/rpmrc:25:optflags: ia64 -O2 -g -m64 --mtune=generic
/usr/lib/rpm/rpmrc:26:optflags: x86_64 -O2 -g -m64 --mtune=generic
/usr/lib/rpm/rpmrc:28:optflags: ia32e -O2 -g -m64 --mtune=generic
/usr/lib/rpm/x86_64-linux/macros:11:%optflags           -O2 -g -m64 --mtune=generic
Comment 1 Panu Matilainen 2007-10-03 01:28:18 EDT
Install redhat-rpm-config for immediate fix (you'll want to have it installed
anyway if you're building packages), the rpm default is already fixed upstream
and will be in F8 final.

*** This bug has been marked as a duplicate of 305221 ***

Note You need to log in before you can comment on or make changes to this bug.