Bug 30559 - installer crashes while loading programs
installer crashes while loading programs
Status: CLOSED DUPLICATE of bug 27550
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-04 12:03 EST by chris
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-25 06:15:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
generated by redhat (1.30 KB, text/plain)
2001-03-04 12:04 EST, chris
no flags Details

  None (edit)
Description chris 2001-03-04 12:03:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en]C-CCK-MCD NetscapeOnline.co.uk  (Win98; U)


Installing red hat for the first time. I have tried on two machines
and get similar faults. I have tried installingon a linux partition
created by partition magic. tried with one by LILO and also
tried with partitionless installtion under DOS, (preferred for my
applications). What happens, during the install process, the program
loads various programs onto the disk. It never completes this task.
On one machine it detects an 'error 11'. This is in 'text' mode
and characters appear all over the screen. They appear to be a
register dump of some sort. The installer attempts to get out of
the mess and unloads something. pressing control/alt/delte halts
the system.  I've tried only loading a few programs, or the absolute
minimum on that machine, and got nowhere.

The second machine I tried it on ran the installer in graphics
mode. Again this went wrong and reported a bug during the
installatin process. The screen display asked me to save the information to 
a dsik, but none of the on screen buttons worked.

I tried again, eliminating  most of the to be installed programs,
and this time i got a big report I could save on disk

I was making a partitionless installtion to on a win98
machine. the other machine ran DOS. Both fail in 'similar' ways

Reproducible: Always
Steps to Reproduce:
1.install from the CD or floppy
2.
3.
	

Actual Results:  it fails to complete the installation

I did succeed once on the machine which has win98 on
a partitionless install. I made the bug report not
appear by eliminating most of the programs and installing
a reduced system. Unfortunately I had to reload as i
was unable to change the screen resolution. (I used
Xconfiguator and got stuck in a 320 display so I
reloaded -- or tried to )


Expected Results:  red hat should load up
At the moment windows wins (much to my disgust)

I have a disk with one bug report on it generated by the machine
Comment 1 chris 2001-03-04 12:04:46 EST
Created attachment 11722 [details]
generated by redhat
Comment 2 jmpenot 2001-03-05 19:05:59 EST
I am having a similar problem but with some differences.  I am installing on an IBM x220 server with ServeRAID 4L.
I am adding to CC list.  I have an Anacdump.txt on floppy if needed.
In mine, the second "File ..." entry is similar to:
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  rc = apply (step[1](), step[2])
Subsequent entries are as:
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in __call__
  if todo.doInstall ():
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1630, in doInstall
     self.copyExtraModules()
File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1348, in copyExtraModules
   os.rename(fromFile, to)
OSError: [Errno 2] No such file or directory

The above happened in graphic install and text install from the Custom Install option.
I used the RH boot diskette, started the install with "Linux dd text" to allow an OS driver diskette from IBM to be used during the boot steps.
I had selected the local CD-ROM for the residence of the installable components and selected that all item be installed.
Disk Druid allowed me to set several partitions.  The installation sequence had asked for the second CD, and it was most of the way
complete when the error occurs.  I do not know enough about Linux to debug the sequence, but I know the error occurs after the RPM data base
is copied from the CD.
If this needs to be a completely new error, please notify me as soon as possible.  But, with this one, 30559, and an earlier bug report
involving RAID specifically, I decided to start here.
Thanks
JonP
Comment 3 Michael Fulbright 2001-03-08 12:01:47 EST
What is your hardware configuration?
Comment 4 chris 2001-03-25 06:15:34 EST
The hardware configuration is determined via the MSDOS 'MICROSOFT
DIAGNOSTICS' command msd.exe#

Computer = award/avant  pentium(tm) award modular bios v 4.51p g
           isa/at classic bus

memory = 640k,31744k ext

video = vga,cirrus
videobios cl-gd544 vga bios veeersion 1.00d

vesa oem name cirrus logic gd-544xvga

I have been able to install win98 on this machine. 
It required the cirrusmm.drv driver

the computer I refere to is the first one i tried it on

thanks

chris
Comment 5 Matt Wilson 2001-04-03 18:21:42 EDT

*** This bug has been marked as a duplicate of 27550 ***

Note You need to log in before you can comment on or make changes to this bug.