Bug 30636 - "vines" screensaver locks up machine
"vines" screensaver locks up machine
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 03:56 EST by phill
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 20:00:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description phill 2001-03-05 03:56:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


Thw "vines" screensaver when activated locks up machine completely. 
Occasionally half of the desktop shows/with half of the screensaver 
This happens after about a minute and a half after the screensaver starts 
If you hi ctrl-alt-backspace after screen freezes, you can restart. If you 
wait more than 5 minutes machine is completely locked.

Reproducible: Always
Steps to Reproduce:
1.Go to desktop settins/screensaver and select "vines"
2.Tried other screensavers, the "matrix" and  "triangles".
3.
	

Actual Results:  The computer did not lock up with the the other 
screensavers. I did not have time to try all though. One time the bottom 
half of the screen did not "clear" but the top half did. The screensaver 
completey completely locked in three minutes though.

System;
Pentium 233 MHz overclocked comfortably at 266 MHz
128 Mb Ram
NCR53c810 SCSI card (tape drive doesn't seem to be mounted though - i 
don't know what's wrong)
tekram  p5t30b4 "TX" based motherboard
Creative Labs Blaster Extreme graphics card 8Mb (permedia chipset - I 
believe this might be related to bug #10974 )

I'm a complete newbie at linux - I can't give you much more detail beyond 
this. Maybe in 6 months :-)
Comment 1 Bill Nottingham 2001-03-05 10:53:13 EST
Does it happen if you don't overclock?
Comment 2 phill 2001-03-06 03:50:15 EST
"vines" is not the only that does this. "Laser" is worse than "vines". I 
removed SCSI card and set system normal (not overclocked). "Laser" almost 
instantly freezes system - no restarting either. One time it went for  twenty 
seconds half the screen flashed blue behind the laser (horizontally) a couple 
of times before it locks hard. Heck, I thought that's why I was leaving 
windows :-)))
Comment 3 Bill Nottingham 2001-03-06 11:32:43 EST
This sounds most like a problem with your speciic X driver; these all
seem to run fine here.
Comment 4 Mike A. Harris 2001-03-06 11:49:43 EST
I cannot reproduce this with r128 card nor a Rage IIc or MGA G200, so I
agree with Bill, it must be specific to your video hardware, or perhaps
your computer setup.  I do not have your hardware available to try to
reproduce this bug.  Can you send me a backtrace from a coredump?
Also, please attach your config, and your X server log file.
Comment 5 phill 2001-03-08 19:59:58 EST
sorry, too much of a newbie to do backtrace/coredump right now. It probably is 
something with this brand of card though.
Comment 6 Mike A. Harris 2001-03-23 01:05:42 EST
Please update to the latest XFree86 in Rawhide (4.0.3) as well as the latest
Mesa.  This should solve the problem.

Note You need to log in before you can comment on or make changes to this bug.